Apache: 403 Forbidden as root@localhost

Discussion in 'Server Operation' started by jsabarese, Jun 3, 2006.

  1. jsabarese

    jsabarese New Member

    i've got a fair amount of experience w/ httpd.conf from WinXP but here in Fedora, which i was expecting to be more intuitive ;) actually seems to be giving me more trouble-- but i'm sure it's me and my inexperience w/ the O/S.

    anyway-- i've had my ups and downs w/ apache so far on this system, from having no output, to directory browsing only, and now i'm at only /localhost/index.html in the browser... i've got another file in /var/www/html , test.html, which i'm linking to from the index.html file, but if i click to go to test.html from index.html, i get a 403 Forbidden error. is that not bizzare?

    i followed a lot of this guide down to creating the www user, and the chmod stuff. from there, when i do the ll command, here's what i get (please compare to what's shown at the link provided)
    [root@localhost www]# ll /home/www/site1/index.*
    -rw-r--r-- 1 www users 170 Jun  2 23:06 /home/www/site1/index.html
    can you get anything from that info? why is there a second line w/ more permissions listed in the guide? ideas?
  2. falko

    falko Super Moderator ISPConfig Developer

    First, Fedora's default document root is /var/www/html, so you must put your HTML files there.
    Then make sure that SELinux is disabled on your system.
  3. jsabarese

    jsabarese New Member

  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, check your forum settings and make sure the notifications don't get sent to your Spam folder. :)

Share This Page