Apache 2 Test Page?

Discussion in 'Installation/Configuration' started by MacBros, Apr 21, 2011.

  1. MacBros

    MacBros New Member

    I am running a CentOS 5.6 server with ISPConfig 3 and I have all the services running fine, but I just added a website: macbrosgb.com, created the DNS Zone, etc, but when I go to macbrosgb.com it takes me to the Apache 2 Test Page.

    At the bottom of my httpd.conf I have:
    Code:
    NameVirtualHost *:80
    NameVirtualHost *:443
    Include /etc/httpd/conf/sites-enabled/
    
    And then in sites-enabled, my macbrosgb.com.vhost file looks like:

    Code:
    <Directory /var/www/macbrosgb.com>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost 174.103.229.131:80>
          DocumentRoot /var/www/macbrosgb.com/web
    
        ServerName macbrosgb.com
        ServerAlias www.macbrosgb.com
        ServerAlias webmail.macbrosgb.com
        ServerAdmin [email protected]
    
        ErrorLog /var/log/ispconfig/httpd/macbrosgb.com/error.log
    
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        <Directory /var/www/macbrosgb.com/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client1/web1/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
    
    So everything seems to be working good, but it still goes to the apache2 test page :(.

    Any help is greatly appreciated!!!
    Shaun
     
  2. MacBros

    MacBros New Member

    Also, when restarting httpd, I get these errors:

    Code:
    
    [[email protected] ~]# /etc/init.d/httpd restart
    Stopping httpd:                                            [  OK  ]
    Starting httpd: [Wed Apr 20 23:15:05 2011] [warn] NameVirtualHost 174.103.229.131:443 has no VirtualHosts
    [Wed Apr 20 23:15:05 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
                                                               [  OK  ]
    
     

Share This Page