Apache 2 Test Page powered by CentOS

Discussion in 'Installation/Configuration' started by Lalas Muathasim M, Nov 25, 2015.

  1. Lalas Muathasim M

    Lalas Muathasim M New Member

    Hi I'm using ISPConfig Ver 3.0.5.4 on CentOS 6
    I think i have messed up with httpd.conf file (/etc/httpd/conf/httpd.conf). i have different domains in the server now whenever i type the website address I'm Getting only "Apache 2 Test Page powered by CentOS"

    Following is the last lines of httpd.conf I have added those lines after reading some of the threads from some other threads.

    Code:
    #<VirtualHost *:80>
    #    ServerAdmin webmaster@dummy-host.example.com
    #    DocumentRoot /www/docs/dummy-host.example.com
    #    ServerName dummy-host.example.com
    #    ErrorLog logs/dummy-host.example.com-error_log
    #    CustomLog logs/dummy-host.example.com-access_log common
    #</VirtualHost>
    
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    
    Include /etc/httpd/conf/sites-available/ispconfig.conf
    Include /etc/httpd/conf/sites-available/ispconfig.vhost
    
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Replace the two lines:

    Include /etc/httpd/conf/sites-available/ispconfig.conf
    Include /etc/httpd/conf/sites-available/ispconfig.vhost

    with:

    Include /etc/httpd/conf/sites-available/

    and restart apache.
     
  3. Lalas Muathasim M

    Lalas Muathasim M New Member

    Thanks for the reply Till but after changing the line i'm not able to restart httpd service it says
    Code:
    Stopping httpd:                                            [FAILED]
    Starting httpd: [Wed Nov 25 08:29:00 2015] [warn] NameVirtualHost *:8080 has no VirtualHosts
    [Wed Nov 25 08:29:00 2015] [warn] NameVirtualHost *:80 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:8080
    and the status of httpd says
    Code:
    service httpd status
    httpd dead but subsys locked
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Change the include line to:

    Include /etc/httpd/conf/sites-enabled/
     
  5. Lalas Muathasim M

    Lalas Muathasim M New Member

    Thank you Till that worked perfectly... Thanks
     

Share This Page