Apache 2 doesn't work

Discussion in 'Server Operation' started by jancoz, Feb 1, 2013.

  1. jancoz

    jancoz New Member

    Hello, I own a hosting company who sells webhosting and gameservers. I began with Ubuntu and that worked fine but I needed CentOS cause one CP I needed didn't support Ubuntu. So I installed CentOS and I know a bit how that works but I really didn't know how to install a webserver.
    So I followed this tutorial:
    http://www.howtoforge.com/installing-apache2-with-php5-and-mysql-support-on-centos-6.2-lamp
    I completed it without problems, but the problem here is that the webserver simply doesn't start. The problem just began from step 3, where you go to your IP of your server in your webbrowser, when I did that nothing happend, but I really did everything right. What can be the problem right here?
    (I've CentOS 6 64bit)

    Thanks

    -Jan
     
  2. falko

    falko Super Moderator

    Did you check Apache's error log?
    What's the output of
    Code:
    netstat -tap
    ?
     
  3. jancoz

    jancoz New Member

    Code:
    [root@localhost ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:mysql                     *:*                         LISTEN      1367/mysqld
    tcp        0      0 *:ssh                       *:*                         LISTEN      1229/sshd
    tcp        0      0 localhost:smtp              *:*                         LISTEN      1458/master
    tcp        0     52 5.157.82.204:ssh            ip4da3a6a5.direct-ads:62317 ESTABLISHED 1604/sshd
    tcp        0      0 5.157.82.204:ssh            ip4da3a6a5.direct-ads:62195 ESTABLISHED 1511/sshd
    tcp        0      0 *:http                      *:*                         LISTEN      1468/httpd
    tcp        0      0 *:ssh                       *:*                         LISTEN      1229/sshd
    tcp        0      0 localhost:smtp              *:*                         LISTEN      1458/master
     
    Last edited: Feb 2, 2013
  4. falko

    falko Super Moderator

    Looks as if Apache is working.

    What's the output of
    Code:
    iptables -L
    ?
     

Share This Page