Apache/2.4.18 (Ubuntu 16.04) + ISPConfig 3.1dev - mod_speling is not working

Discussion in 'Installation/Configuration' started by DCS, Aug 24, 2016.

  1. DCS

    DCS New Member

    I enabled mod_speling
    Code:
    a2enmod speling
    service apache2 restart
    I then added
    Code:
    CheckSpelling on
    CheckCaseOnly on
    into .htaccess file on the root of the website

    That didn't work

    I modified /etc/apache2/sites-enabled/100-abcwebsite.com.vhost file and included
    Code:
    <IfModule mod_speling.c>
        CheckCaseOnly on
        CheckSpelling on
    </IfModule>
    That didn't work

    I went into Sites-> [Clicked on the website] -> Options -> Apache Directives
    and added
    Code:
    <Directory /var/www/abcwebsite.com/web>
    CheckSpelling on
    CheckCaseOnly on
       AllowOverride All
       Require all granted
    </Directory>

    Still not working. Am I missing something?
     
  2. DCS

    DCS New Member

    Am I the only one who is experiencing this issue?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to add this:

    <Directory /var/www/abcwebsite.com/web>
    CheckSpelling on
    CheckCaseOnly on
    AllowOverride All
    Require all granted
    </Directory>

    a second time, but use as path the "real" path /var/www/clients/clientX/webX/web
     
  4. DCS

    DCS New Member

    Thanks, just tried that with same result. Does it matter in what order that is in the file compared to the other stuff in the vhost file?

    Trying to figure out if something in the default directives is messing with this mod.
     
  5. DCS

    DCS New Member

    found another forum with someone having a similar problem and also no solution. Should I downgrade to 3.0? Is this possible?
     
  6. Jesse Norell

    Jesse Norell Active Member

    No, ispconfig 3.0 won't run on ubuntu 16. What does your whole vhost file and htaccess file look like?
     

Share This Page