apache 2.2 and php 5 problems

Discussion in 'Server Operation' started by unkn0wn, Apr 4, 2006.

  1. unkn0wn

    unkn0wn New Member

    i install openssl and it work fine.
    I now to install php 5.1.2 and i have problems with configure

    i use this:

    ./configure --with-apxs2=/usr/sbin/apxs --with-mysql=/var/lib/mysql --enable-track-vars --enable-sockets --with-config-file-path=/etc --enable-ftp --with-zlib --with-openssl=/usr/local/ssl --enable-force-cgi-redirect --enable-exif --with-gd --enable-memory-limit --disable-debug --disable-rpath --disable-static --with-pic --with-layout=GNU --enable-calendar --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-trans-sid --enable-bcmath --with-bz2 --enable-ctype --with-db4 --with-iconv --enable-filepro --with-gettext --enable-mbstring --enable-shmop --enable-wddx --disable-xml --with-xmlrpc --enable-yp --with-zlib --without-pgsql --enable-dbx --enable-experimental-zts --without-mm --enable-gd-native-ttf --with-imap-ssl --enable-soap --enable-dbase 
    but i have an error

    Configuring extensions
    checking whether to enable LIBXML support... yes
    checking libxml2 install dir... no
    checking for xml2-config path...
    configure: error: xml2-config not found. Please check your libxml2 installation.
  2. falko

    falko Super Moderator ISPConfig Developer

    You must install libxml2 first.
    Which distribution do you use?
  3. unkn0wn

    unkn0wn New Member

    debian 3.1 :) sarge

    i wget libxml2 in .deb format.
    i run
    #dpkg --install libxml
    and i have few output lines i suppose its was good instalation :)
    after that there is another error :

    couldnot find libxml2-config? wtf ??
    i can use --disable xml and taht is ok but then i have error
    couldnt find zlib dir??? f*ck :)
  4. 22hosting

    22hosting New Member

    new versions of PHP can be a pig sometimes. I find it's best to explicitly disable anything you don't need (no point in having it there if you don't need it right?). And just to be sure there's not something more at the root of your troubles it might be worth disabling most of the php options to see if it will complete an install. Probably what I would do, but then i'm no genius.

    Having just relooked over the post "xml2-config path" is a path, thus one of the options inside php is probably going to be --xml2-config=</path/to/config> . "checking libxml2 install dir... no" also shows that it couldn't find the libxml2 directory.

    Check http://xmlsoft.org/FAQ.html#Compilatio . It contains some documentation of the xml2-config not being found and how to get around it.

    Update :

    This is what you are looking for :
    xml2-config --cflags
    xml2-config --libs
    locate xml2-config and run the above bits. /path/to/xml2-config --cflags and the --libs one.

    Update :

    zlib is install as one of the default options in PHP5 I believe so if you don't have it installed or you don't have it disabled it will cause an error.

    Update :

    You need to apt-get both libxml2 AND libxml2-dev
    Marijuana card
    Last edited: Aug 22, 2011
  5. unkn0wn

    unkn0wn New Member

    AHHHHH i forget fuckin devele again :))))
    for hundred times :0 tnx man.
    move on
    i have other problem i just cant remove old apache version from my pc?
    apt-get remove --purge , dpkg --remove --purge , aptitude remove
    apache is still present i cant believe :)
    how can i erase that 1.3 shit
  6. 22hosting

    22hosting New Member

    apt-get remove <packagename> should work for debian I believe. You might need to do updatedb or locate -u (or something else for deb) to update the finding functionality of the system. Thus you might still be seeing old information from locate.
    Did you install it from source originally or was it installed as a .deb package?

    If you installed it from .deb you're best off removing it using apt-get remove but if you installed it from source you can either just overwrite the old stuff using --prefix=/path/to/old/httpd or if you're planning on putting it elsewhere just rm -Rf /path/to/old/httpd . I believe it is self-contained if installed from source.
    BabeJennyfer live
    Last edited: Aug 22, 2011
  7. unkn0wn

    unkn0wn New Member

    many many tnx

    i do this step:
    -remove all apache files
    -install openssl from source
    -install apache 2.2 from source
    -instal php5 from source
    and there is no error ) after few hours of work

    PHP cli is working for eg

    give me the correct output. Server info etc....
    But when i go to //ip/info.php i can se and read script ..i dont see output server info etc....i just see

    is there some config in httpd.config

    and now i make init script for httpd with apachectl control..and there was a error:

    /etc/init.d/httpd start
    The startssl option is no longer supported.
    Please edit httpd.conf to include the SSL configuration settings
  8. unkn0wn

    unkn0wn New Member

    ok i menaged it :)
    AddType application/x-httpd-php .php .php5 .php4 .php3

    tnxxxxxxxxxxxx x30000

Share This Page