Apache 1.3 Support

Discussion in 'General' started by SleeperZ, Nov 9, 2005.

  1. SleeperZ

    SleeperZ ISPConfig Developer ISPConfig Developer

    Hi Guys,

    I know that ISPConfig has settled on Apache 2 with the Filters etc, but it would be nice if you could use Apache 1.3 as well. I have run into some major problems with Apache 2 and PHP4 (and PHP5 wasnt much better) which are directly related to PHP's stability on Apache 2.

    It would be nice to be able to offer Apache 1.3 support as well (its still a very popular web server, and in most cases faster than Apache 2)

    What does everyone think?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig already supports Apache 1.3.x and 2.x. If youhave apache 1.3.x on your server installed, this apache will be used.
     
  3. SleeperZ

    SleeperZ ISPConfig Developer ISPConfig Developer

    ok, Now I look like an iddiot :)

    Cheers for this. Is there an easy way to migrate from Apache2 to Apache 1.3 in terms of the settings in ISP Config? (Note: Move this thread if ya need to)
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    At the end of your httpd.conf of the apache 2 you will find a prt related to ISPConfig. This part has to be copied to the httpd.conf of your newly installed apache 1.3. Then there is a symlink from "httpd" to the current apache binary. You can find it with "which httpd". This symlink must point to your apache 1.3 after you installed it.
     

Share This Page