Anybody sucsefuly used Akeeba or Joomlapack with ISPC3?

Discussion in 'General' started by DaRKNeSS666NL, Jun 10, 2010.

  1. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    [SOLVED]Anybody sucsefuly used Akeeba or Joomlapack with ISPC3?

    Hi all,

    Here am I again :rolleyes:

    I have managed to get things up and running on my server I have created 2 sites and I can aces the welcome page on them.

    I was trying to start moving a site from my home server to the server in the data center. My sites are Joomla! based and I use Akeeba Pro to make backups of them.

    I uploaded the site archive and the execution file (kickstart.php) on to the server, and than its going wrong.
    I can execute the kickstart.php file but upon extraction I get rights errors:
    Code:
    Could not open /var/www/clients/client4/web2/web/installation/css/img/busy.gif for writing.
    Even if I set the whole dir to chmod 777 I can't get permission.
    If I log in with FTP I can make directories and put files in them, so than all is fine.

    So guys what am I missing here??

    TIA
     
    Last edited: Jun 15, 2010
  2. Toucan

    Toucan New Member

    I have successfully used joomla pack on isconfig3 before.

    I normally set the site to modphp.

    when you set the whole directory to 777 did you use the
    Code:
    chmod -R 777 yourjoomla directory name
    ?
    make sure you include the -R to recursively unrestrict the whole directory.

    Don't forget to reapply restrictions!
     
  3. till

    till Super Moderator

    For joomla it is recommended to use php-fastcgi + suexec, so that joomla has full wite access to all of its diretories without the need to use chmod 777 and this configuration is also safer then using mod_php, as every website runs under its own user then.
     
  4. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    Till,

    I already knew that I have to use suexec and php-fastcgi so they are enabled.
    I have uploaded the site with filezilla so the files would or must have the right settings I thought.

    But I can't get It to work for me.

    Guess I wil put back my backup and start over again, only thing I can imagine is I have used the wrong follow up of things.
    I think I first uploaded the file and after that I set the settings for the site, found something in an other topic that that is the wrong way off doing things.
     
  5. till

    till Super Moderator

    Please post the output of:

    ls -la /var/www/clients/client4/web2/web/installation/css/img/

    and which Linux distribution do you use?
     
  6. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    output:
    Code:
    server1:~# ls -la /var/www/clients/client4/web2/web/installation/css/img/
    ls: cannot access /var/www/clients/client4/web2/web/installation/css/img/: No such file or directory
    
    But that's normal I guess because the Akeeba backup is put in the:
    /var/www/clients/client4/web2/web/ and than must extract it self to that dir, but if I haven't the wright permission it won't get extracted.

    I am using Debian Lenny setup the perfect way.

    TIA
     
  7. till

    till Super Moderator

    Please extract the backup. The above error message is caused by the fact that the backup has not been extracted yet, so it does not identify any problem on its own.

    If you have enabled fastcgi and the suexec checkbox, then all php scripts have write permissions to the web folder.

    Please post the output of:

    ls -la /var/www/clients/client4/web2/web/
     
    Last edited: Jun 10, 2010
  8. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    That I know, but the working of Akeeba is that it extract for me with the kickstart.php file.

    Code:
    server1:~# ls -la /var/www/clients/client4/web2/web/
    total 3388924
    drwx--x--- 4 web2 client4       4096 2010-06-09 23:23 .
    drwxr-x--x 7 web2 client4       4096 2010-06-10 10:35 ..
    drwxrwxrwx 2 web2 client4       4096 2010-06-08 19:57 error
    -rwxrwxrwx 1 web2 client4     182485 2010-05-20 17:55 kickstart.php
    -rwxrwxrwx 1 web2 client4 3466658258 2010-06-09 23:23 site-www.g-visions.nl-20100609-083146.jpa
    drwxrwxrwx 2 web2 client4       4096 2010-06-09 00:30 stats
    
     
  9. till

    till Super Moderator

    The permissions of the files are fine. What is the complete screen output (error messages) if you start this kickstart.php file?
     
  10. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    Here is my screendump:
    [​IMG]
    Again some permissions isu I think.

    I have formatted my testserver (local) and I am reinstalling it to test it here locally, maybe I did something wrong with the server in the dc??

    Also I will give it a try at my live server with ISPC2 on it (it always have worked on there) to see if there something wrong with the backup image and or install php script.
     
  11. till

    till Super Moderator

    No. It seems as if the backup requires that you install a empty joomla system first, so that a directory installation/img/css/ exists.

    You can esaiuly tet write permissions with a php script:

    <?php
    touch('test.file');
    ?>

    put this in the folder /var/www/clients/client4/web2/web/ and open test.php in the browser. If it creates a file named "test.file" in the web dir, then you have write permissions. If not, create a phpinfo file in this web to check if it really uses suexec and php-fastcgi.

    Thats not nescessary. Thats as if you build a new street because your car does not start instead of checking the car.
     
  12. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    Till,

    First off all thanks for all your help and suggestions..

    The Akeeba software normally doesn't need a empty Joomla!, I use it for several years now (ISPC2) and normally the kickstart.php extracts the backup of the Joomla! site and call's the Joomla! installer to set up the site and database again. It's (normally) a perfect way to backup / clone complete site's.

    I will give the other suggestions a try and will come back again.....
     
  13. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    Done file is created.

    Done it to make sure, I can see: Server API CGI/FastCGI
    But cant seem to find any referance to suexec
     
  14. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    I am getting desperate so I have build a new street 2x I have set up my local test-server here at home, completely fresh with ISPC3 and still it doesn't work. :(

    Second I formatted again and completely reinstalled ISPC2 on my local test-server and voilĂ  everything works right out of the box. :confused:

    Don't know what to do anymore.
    (Don't say switch back to ISPC2 again that I understand.....will work)
    Even the creator of Akeeba is thinking with us at this but he also is :confused:

    Is there a way to give FULL rights to the script on the server I know its not save but even setting the site to 777 recursively doesn't work.
    So just to try it how do I set the whole server wide open give everybody rights to everything (of course I will try this only at my home server)
     
  15. till

    till Super Moderator

    Then it is definately not a permission issue and you use fastcgi with suexec. Suexec is never mentioned in the phpinfo output. But if suexec would have been not enabled, the the file has not been created. Please post the output of:

    ls -la

    from within the web directory.
     
  16. till

    till Super Moderator

    The script has already full rights for all directories in its vhost. You tested this already with the touch command, if it would not have full rights, the touch command would have failed. Please do not set it to 777 or the script will stop as this is a security violation for suexec.

    Please check the error.log of the website if there are any errors and ask the developer of the script that you use if his script has some kind of debugging mode.
     
  17. till

    till Super Moderator

    One other thin: Which exact ISPConfig version do you use and which path have you set as open_basedir path on the options tab of this website?

    Does your backup script tries to open any dependency files from other directories or any external pear libraries?
     
  18. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    Till I am using the latest ISPConfig 3.0.2.1 And this morning before I looked at this post I also was thinking about the open_basedir.
    My lines in there are:
    Code:
    /var/www/clients/client4/web2/web:/var/www/clients/client4/web2/tmp:/var/www/g-visions.nl/web:/srv/www/g-visions.nl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin
    If I put an extra line in there like:
    Code:
    /var/www/clients/client4/web2/backup:/var/www/clients/client4/web2/web:/var/www/clients/client4/web2/tmp:/var/www/g-visions.nl/web:/srv/www/g-visions.nl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin
    I give the user rights to the /backup right? Do I have to restart apache or something else every time, to get the line activated? And do I set the permissions of the dir myself? or as you stated in an other post it will be done automaticly?

    I have contacted the creator of Akeeba to ask if there is an debug mode
     
  19. DaRKNeSS666NL

    DaRKNeSS666NL New Member

    It's solved it was a bug in the script the creator off Akeeba has looked with me on my server to find it out.

    Thanks for thinking along with me, have some issues left but will them ask in other topics, but first I will search for an answer...
     
  20. uiucphoenix

    uiucphoenix New Member

    What was the bug that was found out? I still cannot get it to work.
     

Share This Page