Any input would be appreciated

Discussion in 'Installation/Configuration' started by gwa7, Mar 1, 2008.

  1. gwa7

    gwa7 New Member

    This morning I had serious problems with my mail/web server. I would appreciate anyone's comments on why this happened and how to more quickly solve the problem if it happens again. Here are the details:

    • I moved about 30,000 emails out of an imap email directory to a external usb backup drive.
    • After this I decided to reboot the sever using the reboot command. (I just like to do this from time to time - I guess because I used Windows too long and its a hard habit to break)
    • The fun begins now.
    • I log back in and notice the server is now rejecting all emails with "Relay access denied"
    • I search the forums and find info about virtusertable. I notice on my server that this file has a size of 0.
    • I copied from last nights backup all files that started with virtual* in /etc/postfix. (all the names were in virtusertable on the backup)
    • I rebooted with the reboot command.
    • Now, no websites work and email is still not working.
    • At this point, I start praying a lot.
    • ISPconfig is still working so I decided to create an email account thinking that might cause ISPconfig to re-write its config files.
    • This worked. Websites started working. email appeared to be working except for famd messages. I get the famd messages from time to time, when I reboot they seem to go away. I rebooted and now everything is working fine.

    Any help that might keep this from happening in the future would be highly appreciated!

    Also, I must thank the Lord here because he answered my prayers and help me get my server running again.

    And I want to thank the programmers of this great software and the people of this forum that have helped me in the past.

    Thank you!
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?

    I guess you're using SUSE? :rolleyes:
  3. gwa7

    gwa7 New Member

    No errors now. At the time I was getting relay access denied for every email.
    and then later messages about famd. The only thing I can guess is that I somehow corrupted virtusertable when I rebooted?

    Yes I am using Suse 10.1. I have run no updates on Suse because I was afraid it would break ISPconfig. I have updated ISPconfig to version 2.2.19. Will it break ISPconfig to do the Suse software updates in Yast?

    The only other thing I can think of that might cause problems is this:
    I have created a procmail recipe to forward emails to a certain email account.
    I then created a symbolic link in every user's mail directory to point to this recipe.
    It seems to be working. I did this so that the emails would be forwarded after the spam check. If you think this could cause problems, please let m know.

    I appreciate your help!
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact error messages from the mail log file.
  5. gwa7

    gwa7 New Member

    Thanks for looking at this. The problems begin around line29816 March 1, at 7:37 am. The famd messages begin around line 32992 at 8:45 am.
    By 9:01 am everything seems to be working again.

    I was going to post it here, but it was too many lines and I was afraid I might cut something out that might be important to you.

    Please download the log file here:

    I appreciate your help.

  6. falko

    falko Super Moderator ISPConfig Developer

    I've taken a look at the log, but I'm not sure what the problem is... :(
  7. gwa7

    gwa7 New Member

    Thanks for looking at it!

Share This Page