Antivirus problem

Discussion in 'General' started by edopol, Apr 2, 2020.

Tags:
  1. edopol

    edopol New Member

    Hello everyone, I have a new problem and I can't solve it, I followed an old post but nothing, I uninstalled clamad-demon I reinstalled but the problem remains, I can't find any more info on the internet, the machine is debian 9.

     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What problem?
    If you talk about
    that looks like clamav or parts of it are installed from outside of your Operating System package repository.
    You did not mention what OS you have, so not much I can advice further.
     
  3. edopol

    edopol New Member

    debian 9 ispconfig 3.1.15 amavis is running clamav not, freshclam ??? do I have to reinstall something ?? I updated to 3,1,15 ispconfig and after the emails I arrived **** UNCHECKED ***
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    UNCHECKED means amavis did not run the check for that mail, in this case probably since clamd is not running.
    What show commands
    Code:
    apt-cache policy clamav
    
    apt-cache policy amavisd-new
    
    systemctl --state=failed
    
    apt update
    
    apt dist-upgrade
    
     
  5. edopol

    edopol New Member

    that's all
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Looks like clamav and amavis are the stock versions from Debian 9. Strange that there can then be version mismatch between runtime library.
    Is there a reason you did not run the apt dist-upgrade I asked? That may fix your error if libclamav9 is the package that is not upgraded. You can leave out the apt dist-upgrade, but please run
    Code:
    apt-cache policy libclamav9
    to diagnose the problem.
     
  7. edopol

    edopol New Member

    Code:
    /etc/apt# apt-cache policy libclamav9
    libclamav9:
      Installed: 0.102.2+dfsg-0~deb9u1
      Candidate: 0.102.2+dfsg-0~deb9u1
      Version table:
     *** 0.102.2+dfsg-0~deb9u1 500
            500 http://deb.debian.org/debian stretch-updates/main amd64 Packages
            100 /var/lib/dpkg/status
         0.102.1+dfsg-0+deb9u2 500
            500 http://deb.debian.org/debian stretch/main amd64 Packages
    
    the answer is that 500 that worries me, theoretically is not reachable, right?
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The clamave related packages seem OK and are installed. Strange that library version mismatch.
    Have you checked that freshclam can update the fingerprint database? Is the database now up to date?
    There is some package that is not upgraded, it may be the culprit. I would install that missing upgrade, and reboot. If that does not solve the issue, then examine more.
     
  9. edopol

    edopol New Member

    How do I uninstall the antivirus check from ispconfig, considering that I can't fix it, it's a debian bug and can't fix
     
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you or have you not run
    Code:
    apt-get dist-upgrade
    Which packages did it upgrade?
     
  11. edopol

    edopol New Member

    I lauunched
    Code:
    apt-get dist-upgrade
    but the result was null​
    Code:
    apt-get dist-upgrade
    Lettura elenco dei pacchetti... Fatto
    Generazione albero delle dipendenze       
    Lettura informazioni sullo stato... Fatto
    Calcolo dell'aggiornamento... Fatto
    0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
    
     
  12. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    It is null now, but at message #5 you got "1 package can be upgraded." So somewhere between then and now the upgrade was completed.
    My number one diagnosis has been up to now that some part of clamav was not upgraded and thus the
    Code:
    ERROR: This tool requires libclamav with functionality level 113 or higher (current …vel: 112)
    Have you installed clamav from source or in some other way that is not installing with apt-get from the Debian 9 repository? Is it possible there are now two versions of clamave on your server? The versions that apt-cache policy has shown are the correct ones for Debian 9 Stretch.
     

Share This Page