Anti-spam

Discussion in 'Installation/Configuration' started by alfredo.ardito, Sep 12, 2017.

  1. alfredo.ardito

    alfredo.ardito New Member HowtoForge Supporter

    Hello
    I did a new fresh install following the tutorial The Perfect Server - Debian 9 (Stretch) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1.
    Everything seems to work fine, but I stumbled upon a problem concerning spam. I wanted to check if the spam filtering was working therefore I did a simple test sending an email with the this message in the body as suggested by http://spamassassin.apache.org/gtube/:
    The recipient email address was setup in ispc3 with the option Move Spam Emails to Junk directory set on.
    After sending the email I did not receive it at all and it was not in the spam folder either. I checked mail.log to see what happened to that email and I did not see any trace of it as if it did not arrive at all.
    I can send and receive emails normally but I'm not sure if the spam filter is working.
    Just one more thing. I checked the header if the received emails most of then do not have spam labels like these:
    X-Spam-Flag: NO
    X-Spam-Score:
    X-Spam-Level: *
    X-Spam-Status:
    Other emails not flagged as spam have these labels for example:
    X-Spam-Flag: NO
    X-Spam-Score: 1.428
    X-Spam-Level: *
    X-Spam-Status: No, score=1.428 tagged_above=1 required=4.5
    This means that the spam filter seems somehow working. But the test I did, did not work at all. Is this normal? Is there anything else I need to check or setup?
    Kind regards
     
    Last edited: Sep 12, 2017
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The spam status is this:

    X-Spam-Status: No, score=1.428 tagged_above=1 required=4.5

    The message received a score of 1.428 and the policy that you selected for this email account as a spam tag 2 score of 4.5 which means that spam is recognized as spam (and moved to the spam folder) when its score exceeds the value of 4.5.

    So the spam scan system is workin fine, your test message is simply below the spam level.

    So what you can do:

    a) Use a test message that exceeds the score of 4.5.
    b) Use a spamfilter policy (or edit the current policy) with a spam tag 2 level < 1.428
     
  3. alfredo.ardito

    alfredo.ardito New Member HowtoForge Supporter

    Thank you for the quick reply.
    Okay, I'll try to use different scores to test spam.
    But... what about the test I did sending an email using this in the body message:
    I checked my inbox and junk folder and nothing was there as if it never arrived
    I checked mail.log and this is what I got:
    It seems like the message got removed without ending in the spam folder.
    Shouldn't this email end up in the junk folder flagged as spam?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There are 3 score levels that matter for spam:

    1) The 'tag' level. When a message exceeds this level, then information about the spam scan process is added in the header. This level is not for deciding if a mail is spam or not.
    2) The "tag 2' level, when this level is exceeded, then the spam mail get's marked with "spam status = yes" in the header, the subject lines gets modified (if you configured it) and the mail get's moved into the spam folder.
    3) The third level is the so called 'kill' level. When an email exceeds this level, then the email is deleted directly.

    All 3 levels can be configured in the spamfilter policy. When the message disappeared, then the score was probably above the kill level.
     
  5. alfredo.ardito

    alfredo.ardito New Member HowtoForge Supporter

    Once again I thank you for your attention and remarkable support.
    Okay I understand. I'll do some more testing.
    Just one more thing I'd like to ask you.
    Are outgoing mails filtered as well?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes.
     

Share This Page