Another Postfix setup problem (can't receive emails)

Discussion in 'Server Operation' started by thepreacher, Nov 14, 2009.

  1. thepreacher

    thepreacher New Member

    I am able to send but can't receive emails. I have read a lot of solutions regarding this situation and have tried them but no solution has worked so far. I don't get delievry error however the mail does not arrive. I have created a user [email protected]

    The ff are some related details:
    dig mx
    The content of /etc/mailname is
    What value must i enter for the mx value in the control panel on my domain registrer?
    Last edited: Nov 14, 2009
  2. falko

    falko Super Moderator ISPConfig Developer
    But make sure that really points to your server:
  3. thepreacher

    thepreacher New Member

    Falko thanks for your response. The issue i have is that as you can tell
    is not a proper domain name that has been registered. I cannot therefore i cannot make it point to the server. the Server is behind a 2wire router. I just spoke to the guys at Telivo (now LCN) and they basically said they don't know how i can point the MX record to

    I have a few vitual hosts on the server of which
    is one. They however asked me to change the MX record to and then create a A record with the host as mail and the ip address of the server as the address. I have done that but still no joy.

    Should the mailname be the same as the hostname? If one has a virtual host setup and one wants to be able to create and manage email users for each of the virtual hosts, does your tutorial deal with that? if so which are the relevant areas of your tutorial deals with this?

    Lastly if say i want to go over the whole setup again, what do i need to do to ensure that i have a clean system as far as the mail setup is concerned?

  4. falko

    falko Super Moderator ISPConfig Developer

    That should work, however it can take up to 72 hours until DNS changes propagate.

    Did you create an A record for mail? Because I can't see one:

    server1:~ # dig
    ; <<>> DiG 9.6.1-P1 <<>>
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 40020
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;   IN      A
    ;; AUTHORITY SECTION: 3600    IN      SOA 2008121001 28800 7200 604800 600
    ;; Query time: 109 msec
    ;; SERVER:
    ;; WHEN: Tue Nov 17 18:42:06 2009
    ;; MSG SIZE  rcvd: 107
    server1:~ #

Share This Page