Another PHP error during update

Discussion in 'Installation/Configuration' started by Endimmion, Jan 25, 2008.

  1. Endimmion

    Endimmion New Member

    I was using ISPConfig version 2.2.17 on Fedora 6.
    Then I upgrade my system to Fedora 8 and then I decide to update ISPconfig to version 2.2.19.

    But I got a PHP error. I followed the Clamav fix but it don't work. Have someone an idea?

  2. unclecameron

    unclecameron New Member

    Did you do a fresh install and then try to move your data, or just install over top of it? It sounds like you're having a Perl error, do you have the latest version of Perl installed?
  3. crypted

    crypted New Member

    Try suggestion from other thread.

    Yes you have the latest version of the operating system, and you may in fact also have the latest GCC compiler, but there's a good chance it's still just weird. (GCC version can be checked by 'gcc -v' command, but I bet it's 4.1.2)

    I had this issue on the latest CentOS 5.x branch this evening... Just do the quick fix and you'll be on your way to success and women; maybe not the latter.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It looks as if the following perl module is missing:


    After you installed that module, make sure that you run the following command:

    mkdir /root/ispconfig

    before you try to run the ispconfig setup script again.
  5. Endimmion

    Endimmion New Member

    Installing ExtUtils::MakeMaker solve my problem :)

    thanks for your help

Share This Page