annoying folder problem

Discussion in 'Installation/Configuration' started by timaaarrreee, Jun 9, 2008.

  1. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    i have another thead about having trouble with installing a forum program called simple machines forum i think i have an answer but its very weird have a look at this error:

    ===================================================
    Warning: Invalid argument supplied for foreach() in /var/www/web9/web/forums/webinstall.php on line 607

    Warning: unpack() [function.unpack]: Type H: not enough input, need 1, have 0 in /var/www/web9/web/forums/webinstall.php on line 1051
    The installer was unable to download the archive (http://download.simplemachines.org/index.php/smf_2-0-beta3-1p_install.tar.gz) from the server.
    ===================================================

    Now for some reason the script thinks it in the diretory /var/www/web9/web/forums/webinstall.php BUT it isn't!!! it is the folder /var/www/forums.khost.co.nz/web/forums/webinstall.php

    Why does it say there is a folder named web9 in my /var/www folder

    I am sure that this is the problem that i have been posting in other threads :eek:
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The script is correct, the folder is /var/www/web9/web/forums/. The directory /var/www/forums.khost.co.nz/web/forums/ is just a symlink to the web9 flder to make the navigation on the shell easier. This is not related to your problem as both paths can be used eaqually.

    Maybe you activated PHP safemode which may cause trouble with many scripts. Also make sure that the path were the forum software wants to download the file is writable for the websever process.
     

Share This Page