analyzing server performance

Discussion in 'Server Operation' started by Ovidiu, Mar 16, 2007.

  1. Ovidiu

    Ovidiu Active Member

    hi there,

    I wanted to know if I can get more out of my server by changing configuration. what details would you need?

    I'll make a list and will wait for you to contribute other info you would need.


    - OS: debian 3.1
    - PHP 4.3
    - Mysql 4.0
    - Apache2


    - CPU: AMD Athlon(tm) 64 Processor 3200+ stepping 0
    - 1GB RAM
    - 2x 80GB HD using softraid for mirrroring

    some graphs as info: and

    The thing is CPU is pretty much constantly high, I have set apache2 with maxprocesses somewhere around 75 and an average apache2 proccess is around 24MB so it all maxes out pretty fast. This is the main problem.

    I just wanted to make sure, the server is running optimally. I will have another client wit ha lot of traffic in a few weeks and wanted to make sure verything was optimized. Mysql is optimized, apache might be, but still a proxying of static requests to a second web server even another one aka lighttpd might help. I am open for suggestions, I saw some ppl in this forum have successfully introduced a second webserver for ruby, if someone feels competent enough to help me out, contact me.
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you use eAccelerator for your PHP applications?
    Maybe you can also cache some of your web sites, this should lower the load average tremendously.
  3. Ovidiu

    Ovidiu Active Member

    I use eaccelerator (thx to a hint in another post from you :)

    besides that, the biggest site is basically a huge coppermine photogallery which uses my expensive apache processes to serve its images => hence my repeated asking about howto setup a second lightweight webserver for static content...
  4. Ovidiu

    Ovidiu Active Member

    I made a big mistake.

    After the last php update done with apt-get I forgot to compile and insatll eaccelerator again, the settigns were still inside the php.ini but I had formerly compiled eaccelerator for the older php evrsion, that got replaced on my system.
    I installed and compiled it again, and now at least the system load is doan again :)

    BUT I have one big question regarding eaccelerator, which I read on their foru m too, but none respondend. What exactly do these settigns do:

    These explanations are from their site but I simply do not udnerstand them as you can itnerpret them in severall ways.

    I want to remove scripts that have not been accesses during the last hour, aka 3600 seconds. so Iwoudl set that to eaccelerator.shm_ttl = 3600 but what about that prune period? how does one affect the other? I played around a lot with these settings, but still when I access the eaccelerator control page, it says 1 reload for every script and 0 scripts removed, so I must be doing something wrong.

    btw. still using version 0.94
  5. falko

    falko Super Moderator ISPConfig Developer

    I understand what eaccelerator.shm_ttl is, but I don't know the difference between eaccelerator.shm_ttl and eaccelerator.shm_prune_period... :eek:

Share This Page