An oddity - when i use fqdm to access ispconfig now display issue?

Discussion in 'ISPConfig 3 Priority Support' started by craig baker, Sep 1, 2020.

  1. craig baker

    craig baker Member HowtoForge Supporter

    very odd. when I access my server as https://ns9.cdbsystems.com:8080 and https://cdbsystems.com:8080 I dont get the same display its like some library has not loaded. pulldown boxes are not pulldown boxes. have a look.
    the cdbsystems.com:8080 access (even with the security issue as the SSL is for ns9) gives correct appearence, and my 'normal' access to ispconfig has the incorrect displaying of the boxes. (second image).

    any idea whats going on? most curious just started happening. I updated most of the site to php 7.2 but it seems not to matter what php the vhost entry (ns9) has!
    thanks!

    ispconfig2.PNG ispconfig1.PNG
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISPConfig UI should be accessed through the hostname of the server and not through another domain. If you use another domain, your browser might block parts of the displayed page due to a wrong SSL cert being used. Also browser plugins like spam or js blockers might cause similar effects.
     
    Th0m likes this.
  3. craig baker

    craig baker Member HowtoForge Supporter

    I would sort of expect that but its my HOSTNAME (normal and worked till just recently) access URL that gives the wrong display, and its only through OTHER domains that I get the correct ispconfig3 display!!! (even with the security issues!).
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Have you tried a different browser?

    Can you open the dev panel of your browser and check in the console if there are any 404 errors?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    dev mode of the browser is a good idea indeed, look for all kind of loading errors incl. SSL errors.
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    I get a certificate error for cdbsystems.com, that's probably the issue:
    Code:
    This server could not prove that it is cdbsystems.com; its security certificate is from ns9.cdbsystems.com.
     
  7. craig baker

    craig baker Member HowtoForge Supporter

    Yes the cert is for ns9.
    But NS9 is the one displaying incorrectly
    Cdbsystems.com:8080 gives cert warning BUT DISPLAYS PAGE CORRECTLY!
    Go figure!
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    What I see when I access ns9 is that you seem to have mod_pagespeed enabled globally and this might cause the issue, Try disabling pagespeed for the ispconfig vhost by editing the ispconfig.vhost file and then restart apache.
     
  9. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Please answer this if disabling pagespeed doesn't fix it.
     

Share This Page