amavisd start problem

Discussion in 'Installation/Configuration' started by darkspirit386, Mar 24, 2010.

  1. darkspirit386

    darkspirit386 New Member

    I'm trying to set up a home server using the "The Perfect Server - CentOS 5.4 x86_64 [ISPConfig 3]" tutorial. So far, I followed the tutorial perfectly, without a mistake. But now, on page 5, it is said to start the amavisd service, which fails and return the following:
    Starting virus-scanner (amavisd): The value of variable $myhostname is "static-host", but should have been
    a fully qualified domain name; perhaps uname(3) did not provide such.
    You must explicitly assign a FQDN of this host to variable $myhostname
    in amavisd.conf, or fix what uname(3) provides as a host's network name!
    I tried to look for a solution, and came out empty-handed.

    Any idea on how to continue with my installation?

    Thank you!
  2. wpwood3

    wpwood3 New Member

    What is the output of:
    uname -n
  3. jseedev

    jseedev New Member

    uname -n likely returns static-host ... I had the same problem when following the guide. I simply continued with the setup. Once completed and ISPconfig was running, I setup all the DNS records for my primary domain zone (including a 'A' record) and awaited propagation.

    I then edited /etc/amavisd.conf and located this setting:
    #$myhostname = ''; # must be a fully-qualified domain name!

    and changed it to:
    $myhostname = ''; # must be a fully-qualified domain name!

    Started amavisd and all was good. Hope this helps.
  4. darkspirit386

    darkspirit386 New Member

    Just like jseedev said, uname -n returns static-host. I'll try your tip and see if it works. Thanks!
  5. HellScream

    HellScream New Member

    FIX that worked for me

    hostname <new hostname>
    try to be something like ""

    I put "" and it work.
    hope it will work for you too.
  6. xalop

    xalop New Member

    Worked for me .. Thanks!

    Worked for me - Thanks!

Share This Page