amavisd-new genrsa errors

Discussion in 'General' started by aleksey, May 7, 2010.

  1. aleksey

    aleksey New Member

    I'm trying to implement dkeys for my domain, but when i try to generate rsa keys i get this error :
    Problem in Amavis::Tools code: Can't locate Crypt/OpenSSL/ in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at (eval 79) line 22.
    BEGIN failed--compilation aborted at (eval 79) line 22.

    I'm using debian with ispconfig 3.
  2. falko

    falko Super Moderator ISPConfig Developer

    Please run
    aptitude install libcrypt-openssl-rsa-perl
  3. aleksey

    aleksey New Member

    that worked great I was able to create the keys
    but now if I try to run
    amavis-new showkeys or amavis-new testkeys
    I get
    Problem in Amavis::DKIM code: Can't locate Mail/DKIM/ in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at (eval 80) line 26.
    BEGIN failed--compilation aborted at (eval 80) line 26.
  4. aleksey

    aleksey New Member

    I found the answer
    so i will post for other people that have the same error

    Go to the PERL shell

    run perl -MCPAN -e shell

    and then run

    install Mail::DKIM::Verifier

    exit with q
  5. aleksey

    aleksey New Member

    i have another error i tried the tutorial from

    but every time I do amavisd-new testkeys
    I get a dns error
    TESTING: foo._domainkey.xxxxxx.xx => invalid (public key: DNS error: SERVFAIL)

    the key is in the DNS record with

    v=DKIM1; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC9Wqbrpm4NDcPUlNVsdrvTElCQlmHJkapBzhz3NYRsW+OrqtllheG4Y0fO2Zz71FSZ+0XkGatxqK5vys/7hI149S8c6dZ7NA8lvcKU9mmQwvFF0AsHRbFZheB5S2F8w9sShbCsEzxQD7tb36yAMjaUJsxTKrqXAVfumRn+IY1azQIDAQAB

    any ideas why I get the DNS error ?

Share This Page