Amavisd-new, f-protect ver. 6

Discussion in 'Installation/Configuration' started by CrankyCronos, Nov 27, 2007.

  1. CrankyCronos

    CrankyCronos New Member

    I am currently looking for a how to on configuring the new f-protect ver. 6 MS deamon with amavisd-new. It works really well with the 4.6.8 version. Anyone seen one or know how to configure it?
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried version 6 with amavisd? Did you get any errors?
  3. CrankyCronos

    CrankyCronos New Member

    It never makes the connection.

    amavis[20325]: (20325-06) (!!)WARN: all primary virus scanners failed, considering backups

    The folks at f-secure openly admit in there readme that they changed the code for version 6 and how it talks to 3'rd party applications. No info out of the f-protect camp even as we speak although I have specifically asked.

    readme file attached.

    Attached Files:

  4. falko

    falko Super Moderator ISPConfig Developer

    I think you must modify the F-Prot code in the amvisd configuration to use fpscan or fpscand. Take a look at
    man fpscan
    fpscan --help
    to find out what options are available.

Share This Page