Amavis won't start on systemctl

Discussion in 'Server Operation' started by jfreak53, Sep 20, 2018.

  1. jfreak53

    jfreak53 New Member

    I have a fresh install of Ubuntu 18.04.1 that I have installed ISPConfig 3 on. I've done this same install multiple times with no problems. For some reason this time Amavis won't start at all using init scripts.

    If I run `systemctl restart amavis` it gives me this:
        amavis.service - LSB: Starts amavisd-new mailfilter
           Loaded: loaded (/etc/init.d/amavis; generated)
           Active: active (exited) since Thu 2018-09-20 08:52:55 EDT; 1s ago
             Docs: man:systemd-sysv-generator(8)
          Process: 3587 ExecStop=/etc/init.d/amavis stop (code=exited, status=0/SUCCESS)
          Process: 3596 ExecStart=/etc/init.d/amavis start (code=exited, status=0/SUCCESS)
        Sep 20 08:52:55 systemd[1]: Starting LSB: Starts amavisd-new mailfilter...
        Sep 20 08:52:55 amavis[3596]: Starting amavisd:
        Sep 20 08:52:55 amavis[3596]: Warning: Fake start-stop-daemon called, doing nothing.
        Sep 20 08:52:55 amavis[3596]: amavisd-new.
        Sep 20 08:52:55 systemd[1]: Started LSB: Starts amavisd-new mailfilter.
    Then running `netstat -tap | grep amavis` returns nothing. Checking syslog there are no conceivable errors other than the `Fake start-stop-daemon` error.

    However, if I run `amavisd-new debug` it starts fine, and netstat does return results:
        tcp        0      0 localhost:10024*               LISTEN      3986/amavisd-new (m 
        tcp        0      0 localhost:10026*               LISTEN      3986/amavisd-new (m 
        tcp6       0      0 localhost:10024         [::]:*                  LISTEN      3986/amavisd-new (m 
        tcp6       0      0 localhost:10026         [::]:*                  LISTEN      3986/amavisd-new (m
    So I don't think it's the config since it start fine there and mail delivery then works on this server. But through init scripts it doesn't start.
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Did the install finish without errors?
    Check /var/log/dpkg.log.
    dpkg --list | grep -v "^ii"
    To see if some installed package is not installed completely.
  3. jfreak53

    jfreak53 New Member

    No, i didn’t have any errors during install.
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name                                  Version                            Architecture Description
    rc  apparmor                              2.12-4ubuntu5                      amd64        user-space parser utility for AppArmor
    I followed how to forge’ guide on Ubuntu 18 install of ispconfig3. This same process worked fine for mx1, but errors on mx2.

    Is there some known error on 18? Since dovecot is also not automatically syncing between mx1 and 2, it does manually just not automatically. I’ve got the same setup for 16 with no issues, this is my first 18 server and it is riddled with issues.
  4. jfreak53

    jfreak53 New Member

    I should mention mx1 also has that same output, but no errors with amavis as mx2 does. I also removed and purged apparmor before installing all components.
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I don't understand what the fake start-stop-daemon is about. Check on your host like this:
    dpkg --listfiles dpkg | grep -i start
    ls -lh /sbin/start*
    file  /sbin/start*
    Do you have several start-stop-daemon* files in your /sbin? Or somewhere else, check with
    locate start-stop-daemon

Share This Page