Amavis Startup Errors

Discussion in 'Server Operation' started by kevinfc, Dec 14, 2006.

  1. kevinfc

    kevinfc New Member

    Hey all. I am almost complete my first Postfix install and am hung up on the last part ... starting Amavis.

    When I run this command to check it out: /usr/local/sbin/amavisd -u amavis debug

    I get the following error:

    Problem in the Amavis::Unpackers code: Can't locate Convert/ in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site _perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/ perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.6/i38 6-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib /perl5/vendor_perl /usr/lib/perl5/5.8.6/i386-linux-thread-multi /usr/lib/perl5/5.8.6) at (eval 57) line 18.

    So far I have been really good and deciphering a lot of the problems installing, but I can not find anything on this. I just got the BerkleyDB Perl mod installed and everything else required (I believe). I will go back through and check.

    Does anyone have any thoughts on this? Any help would be really greatly appreciated.


  2. falko

    falko Super Moderator ISPConfig Developer

    You must install the Convert::UUlib package.
    perl -MCPAN -e shell
    If you run it the first time, you have to answer some questions; you can accept the default values.
    Then run
    install Convert::UUlib
    Afterwards type
    to leave the Perl shell.
  3. kevinfc

    kevinfc New Member


    Sigh ... thank you very much. After i read your post I read the first line of the error and thought, "wow, i really did miss that one". lol.

    Installed and worked great. Much appreciated.


Share This Page