Amavis Socket Error

Discussion in 'Installation/Configuration' started by sunghost, Jul 27, 2016.

  1. sunghost

    sunghost Member

    Hi,
    i have installed on Jessie ISPConfig 3.1 after Howto and see now in mail.log these:
    Any Idea?
    thx
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Sounds like clamd is not running. Try 'service clamav-daemon start' .. if it won't start for some reason, check the errors/logs messages.
     
  3. sunghost

    sunghost Member

    Hi,
    checked and found this error:
    - ERROR: Parse error at line 90: Unknown option AllowSupplementaryGroups
    - ERROR: Can't open/parse the config file /etc/clamav/clamd.conf
    The option mentioned is not in my 2 testserver and i didnt add this line, but i tried never to send mails. any idea?

    edit: compared to old running server without ispc, its also in the config and true, but running - permission problem?
    edit: some info under monitor and service would be nice :)
    edit: could be this bug "https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=826406" or?
     
    Last edited: Jul 27, 2016
  4. Jesse Norell

    Jesse Norell Well-Known Member

    Yes, that's the bug you're hitting; just comment out the AllowSupplementaryGroups line.
     
  5. sunghost

    sunghost Member

    Hi,
    ok thats what i found too, but on the 2 testsystems its not comment out and clamd is running. how do you explain that? And did i understand the bug report right and it will be outcommented in future? What is that option for? As far as i understand, with this option clamav can read all files and not only from own group... could it be an problem if i commended out?

    edit: found same problem and answer in german ispconfig forum too - i think its solve for me, but as a feature request i whould wish, that this is commended out in the howto and under monitor and service it would show status of amavis :)
     
    Last edited: Jul 27, 2016
  6. Jesse Norell

    Jesse Norell Well-Known Member

    They would be running older versions of clamd, where that option was supported.

    The bug report says the solution is to just ignore that old option:
    File a feature request at https://git.ispconfig.org/ispconfig/ispconfig3/issues
     
  7. sunghost

    sunghost Member

    Hi,
    no they have the same version. The 2 Testsystems setup like the new Prodsys and i compared the versions, all the same ?! Ok i looked again into amavis.conf and on the testsystems its not included. One thing i now remember is: On Prodsystem i forged to install MPP like in the howto. I do the steps in the howto afterwards and run update.php from ispc. perhaps this sets the wrong option again?! can you check that?
     
  8. Jesse Norell

    Jesse Norell Well-Known Member

    A quick grep doesn't find it, so I'd guess it does not:
    Code:
    [email protected]:~# grep -R AllowSupplementaryGroups /usr/local/ispconfig
    [email protected]:~#
    Also anecdotally, I've been installing git-stable updates frequently here and haven't run into that.
     
  9. sunghost

    sunghost Member

    Hi,
    i have no results too. Ok strange, but i think solved. Many thx for your fast help.
     

Share This Page