Amavis Postfix problems

Discussion in 'Server Operation' started by ripit, Dec 3, 2006.

  1. ripit

    ripit New Member

    Hi
    I've setup a mailserver with postfix, amavis, mysql and spamassassin whith virtual users. If I send a mail to a user that isn't in amavis db the message get rejected by postfix and returned to sender and this only seems to happen if the user doesn't have directories created, by that I mean if add them to amavis send mail and then remove them again it works. If anybody understands what I mean and have a clue please help.

    /Johan
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any error messages in your mail log?
    Did you follow a tutorial from HowtoForge? If so, which one (URL)?
     
  3. ripit

    ripit New Member

    Hi,
    form the beginning I followed this tutorial, http://www.howtoforge.org/perfect_setup_ubuntu_6.06, and installed ispconfig. After testing it I didn't want to use ispconfig and uninstalled it. I then tried to set the server up according to this tutorial, http://www.howtoforge.org/virtual_postfix_mysql_quota_courier, not reinstalling the whole server. I then setup amavis with per user config in mysql. Everything works fine (I think) but some users can't recieve mail untill I add them to amavis database and some can. Thats the strange thing why do I have to add one but not another. The obvious solution would be to automtically add all new users to amavis and then everything would hopefully work, but I don't want to do this.

    Mail.log

    Dec 3 03:48:58 365724 amavis[15740]: (15740-05) Not-Delivered, <[email protected]> -> <[email protected]>, quarantine 9bZS\
    U82BFCyQ, Message-ID: <001d01c71685$cf95a220$5f00a8c0@hemmahos>, Hits: 5.584
    Dec 3 03:48:58 365724 postfix/smtp[16719]: 582CD1E0405: to=<[email protected]>, relay=127.0.0.1[127.0.0.1], delay=8, \
    status=bounced (host 127.0.0.1[127.0.0.1] said: 550 5.7.1 Message content rejected, UBE, id=15740-05 (in reply to end o\
    f DATA command))


    And I also noticed some other errors (warnings) in my mail log concerning smtpd.cert and TLS.

    Mail.log


    Dec 3 03:48:49 365724 postfix/smtpd[16713]: warning: cannot get certificate from file /etc/postfix/smtpd.cert
    Dec 3 03:48:49 365724 postfix/smtpd[16713]: warning: TLS library problem: 16713:error:02001002:system library:fopen:No\
    such file or directory:bss_file.c:349:fopen('/etc/postfix/smtpd.cert','r'):
    Dec 3 03:48:49 365724 postfix/smtpd[16713]: warning: TLS library problem: 16713:error:20074002:BIO routines:FILE_CTRL:\
    system lib:bss_file.c:351:
    Dec 3 03:48:49 365724 postfix/smtpd[16713]: warning: TLS library problem: 16713:error:140DC002:SSL routines:SSL_CTX_us\
    e_certificate_chain_file:system lib:ssl_rsa.c:720:
    Dec 3 03:48:49 365724 postfix/smtpd[16713]: cannot load RSA certificate and key data


    maybe you or someone else knows how to solve these warnings.

    /Johan
     
  4. falko

    falko Super Moderator ISPConfig Developer

    These tutorials are not compatible, so I think the best would be a clean reinstall, using only one of them.

    About what amavisd database are you talking? :confused:
     
  5. ripit

    ripit New Member

    Hi again,
    the database is a mysql that I set up for amavis to get the users spamcomfiguration, http://www.ijs.si/software/amavisd/README.sql.txt it's described here. I think I solved that problem. It was when a user that wasn't in the db got a spammail the mail was rejected. I solved this by commenting out the sa_taglevel things in the config. So now a new user that isn't in the db doesn't get his mails scanned and if I add him to the db and set his levels mails get checked.
    For now everything works fine but I only use pop and imap so i don't know if it would work if I use encryption. That is why I would like to get rid of those warnings about smtpd.cert and tls but not reinstall the server. So if you got any ideas I would be very happy.

    By the way it's some really nice tutorials you got here.

    Many thanks
    Johan
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Try to recreate the certs and accept all the default values. I guess you entered some invalid details in your previous try.
     

Share This Page