Amavis/postfix problems

Discussion in 'Installation/Configuration' started by irDante, Jul 30, 2006.

  1. irDante

    irDante New Member

    Hi, i seam to be having this problem,
    mail arrives and gets into trouble somehow, i have read through most of this forum and the archives and seen some people have had similar porblems. i have tried thier fixes but it still is giving this error and not delivering the emails.

    i have gone over the setup a few times to see if i have missed something but all looks 100%

    the first line has me confused about the "provider.policy" - i havent ever used that in any file anywhere and i just cant find where its ref to?


    Jul 30 15:35:40 sphereonline amavis[3249]: (03249-01) lookup_sql: 1146, Table 'provider.policy' doesn't exist
    Jul 30 15:35:40 sphereonline amavis[3249]: (03249-01) TROUBLE in check_mail: creating_partsdir FAILED: DBD::mysql::st execute failed: Table 'provider.policy' doesn't exist at (eval 38) line 238, <GEN9> line 17.
    Jul 30 15:35:40 sphereonline amavis[3249]: (03249-01) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20060730T153539-03249
    Jul 30 15:35:40 sphereonline MailScanner[9938]: MailScanner E-Mail Virus Scanner version 4.41.3 starting...
    Jul 30 15:35:40 sphereonline postfix/smtp[9911]: DAD09240C64: to=<[email protected]>, relay=127.0.0.1[127.0.0.1], delay=5, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=03249-01, creating_partsdir FAILED: DBD::mysql::st execute failed: Table 'provider.policy' doesn't exist at (eval 38) line 238, <GEN9> line 17. (in reply to end of DATA command))



    Thanx in advance
     
  2. todvard

    todvard ISPConfig Developer ISPConfig Developer

    Which distribution are you using? What is the version of the amavis and postfix? Have you used a "perfect setup" howto from Falko?
    Anyway, it seems from the error message that your amavis is configured to use mysql for lookup tables, check the amavis.conf file at lines 17, 238. You can even start amavis in debug mode in which it will tell you if an error exists in the config file.
     
  3. falko

    falko Super Moderator ISPConfig Developer

  4. irDante

    irDante New Member

    thanx yes. my amavis.conf file was slightly diff for some reason, maybe i never saved on an exit at some stage. I recopied it and all working as you said.

    Thanx
     

Share This Page