Amavis on wrong port on Debian 11

Discussion in 'Installation/Configuration' started by Stefan Schumacher, Jul 27, 2021.

Tags:
  1. Stefan Schumacher

    Stefan Schumacher New Member

    Hi
    I tried ISPconfig on Debian 11, which is supposedly going to be released on Saturday. Nearly everything works fine, but I have a problem which even a reconfigure with php update.sh --force could not fix. If I try to send emails from Thunderbird - I can receive Emails by the way - I get the following error message in mail.log:
    mail2 postfix/lmtp[1964521]: connect to 127.0.0.1[127.0.0.1]:10026: Connection refused
    I assume this is Postfix trying to connect to Amavis to scan my email which is running on port 10024.
    The strange thing: There is already a line :
    content_filter = lmtp:[127.0.0.1]:10024 in /etc/postfix/main.cf.
    How can I either a) make Amavis accept Emails on port 10026 or b) have them delivered by Postfix to 10024, where Amavis is already waiting.

    Yours sincerely
    Stefan
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Amavis should be listening on both ports; is it running?
     
  3. Stefan Schumacher

    Stefan Schumacher New Member

    ● amavis.service - Interface between MTA and virus scanner/content filters
    Loaded: loaded (/lib/systemd/system/amavis.service; enabled; vendor preset: enabled)
    Active: active (running) since Mon 2021-07-26 16:09:21 CEST; 24h ago
    Docs: http://www.ijs.si/software/amavisd/#doc

    [email protected]:~# netstat -tulpen | grep amavis
    tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN 114 3581946 1588212/amavisd-new
    tcp6 0 0 ::1:10024 :::* LISTEN 114 3581947 1588212/amavisd-new
     
  4. Stefan Schumacher

    Stefan Schumacher New Member

    Oh, and I found this in /etc/amavis/conf.d/50-user:
    $inet_socket_port = [10024,10026];
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to restart amavis.

    As a side note: Debian 11 is not supported yet, ISPConfig does not ship with a config file set for it nor is it able to recognize this OS. And for new systems, I highly recommend using Rspamd instead of Amavis.
     
  6. Stefan Schumacher

    Stefan Schumacher New Member

    Restarting did not fix the problem. I know that ISPConfig is not yet targetted at Debian 11, but it seemed at least worth trying considering that from Saturday on Debian 10 is going to be Oldstable. Setting up a new email Server on an Oldstable seemed counterproductive. But thanks for the advice, I will have a look at Rspamd.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

  8. Stefan Schumacher

    Stefan Schumacher New Member

    Hello

    I followed the Instructions, but reconfiguring services throw one error:
    Configuring Rspamd
    chgrp: Zugriff auf '/etc/rspamd/local.d/worker-controller.inc' nicht möglich: Datei oder Verzeichnis nicht gefunden
    chmod: Zugriff auf '/etc/rspamd/local.d/worker-controller.inc' nicht möglich: Datei oder Verzeichnis nicht gefunden
    The file worker-controller-inc exists and has the following permissions. It was changed three minutes ago, so the update script did modify it during its run.
    -rw-r--r-- 1 root root 242 28. Jul 11:47 worker-controller.inc

    --------------------------------------------------------------------------------------
    [email protected]:/etc/rspamd/local.d# cat worker-controller.inc
    # Included from top-level .conf file
    type = "controller";
    count = 1;
    password = "$2$7shazzwbbeb736ewytfptw5e78gc1eut$5md73mxrxnbof1u5cjmouwycsnti94hzeowi6ggk9u77y4zscfwb";
    secure_ip = "127.0.0.1";
    secure_ip = "::1";
    --------------------------------------------------------------------------------------

    Can I ignore these warning or is there something I would have to do manually?

    Yours sincerely
    Stefan
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    You can ignore the error.
     
  10. Stefan Schumacher

    Stefan Schumacher New Member

    Good news. I can now send outgoing mails. I am going to test the setup at little with different mailclients. If anything of interest happens I will report back in a different thread since the topic of this thread has obviously changed from amavis to spamd.
    Yours sincerely
    Stefan
     
    Th0m and till like this.
  11. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    The file should be mode 640, group _rspamd:
    Code:
    -rw-r----- 1 root _rspamd    242 Apr 20 13:31 worker-controller.inc
    
    Perhaps there's an error in the updater that runs chown/chmod before having copied that template into place? I wouldn't expect that to be specific to Debian 11, but who knows.
     

Share This Page