amavis and Zlib

Discussion in 'Installation/Configuration' started by korbynn, Oct 10, 2010.

  1. korbynn

    korbynn Member

    I have updated to the latest ispconfig version.
    Also before this I updated my CentOS 5.4 OS with yum making sure that postfix is not updated.

    amavis is now not running. Attempting to start amavis results in the error:
    error loading required module Compress/
    dualvar is only available with the XS version of Scalar::Util ...

    I have fixed this before but I am having a problem finding that fix.
    In the mean time I have disabled amavis so that I mail can be delivered.

    Last time I believe I fixed it by updating CPAN. This has not worked this time.

    Does anyone out there know of fix?
  2. falko

    falko Super Moderator ISPConfig Developer

    You can open the Perl shell and run
    install Compress::Zlib
    to install the missing module.
  3. korbynn

    korbynn Member

    Compress:Zlib is up to date also Scalar::Util is up to date.
    I am trying to deal with the dualvar and XS version of Scalar::Util which amavis dies on.
  4. korbynn

    korbynn Member

    I found a fix. I am posting it here so that the next time I have this problem I can find a solution here.

    Get a copy of Scalar::Util with XS in place:
    cd /tmp/
    tar zxvf Scalar-List-Utils-1.22.tar.gz
    cd Scalar-List-Utils-1.22
    perl Makefile.PL
    make test install

    Go into cpan and reinstall Compress::Zlib
    cpan[1]> install Compress::Zlib

    Once this is done then restart amavis on CentOS 5:
    /etc/init.d/amavisd start

    If amavis does not start then there is another problem.

    Now I just have to go back to Postfix and enable amavis


Share This Page