Amanda Disk Based Backups Error! A little help

Discussion in 'HOWTO-Related Questions' started by deniscyrillo, Jun 2, 2008.

  1. deniscyrillo

    deniscyrillo New Member

    Hi there!

    I found this great howto in this link (here)

    Everything goes fine until i have to label the virtual tapes with amlabel. I get some errors when running the command "for i in 1 2 3 4 5 6; do /usr/sbin/amlabel DailySet1 DailySet1-${i} slot ${i}; done"

    It's appears that my amanda.conf have some errors, and i don't know how to solve this issue. The error is that:

    "/etc/amanda/amanda.conf", line 262: tape type parameter expected
    "/etc/amanda/amanda.conf", line 262: end of line is expected


    Any suggestions? Please, if someone know this issue, share with me, i really need help. :(

  2. falko

    falko Super Moderator ISPConfig Developer

    What's in line 262 of /etc/amanda/amanda.conf? Is it the last line of the file?
  3. deniscyrillo

    deniscyrillo New Member

    Hi Falko,

    No it's not the end of the file. It's in the middle of the file.

    I'm uploading my amanda.conf in rapidshare, so you can access and view my file.

    Here is the link: amanda.conf

    Thanks for your help!:rolleyes:
  4. deniscyrillo

    deniscyrillo New Member


    Thanks for your reply Falko.

    I solved the issue. The problem is that the tapetype definition MUST be in dumptype session.

    The default conf file with debian Etch comes with a lot of commentaries, and in my amanda.conf i was setting my " define tapetype" ind the tapetype session (by default already have others tapetypes), but that way the error appears.

    Then, when i set my tapetype device inside de dumptype session, its seems that the issue was solved.


Share This Page