Allow postfix server sent email without domain enabled.

Discussion in 'Server Operation' started by Olgierd, Jan 21, 2021.

  1. Olgierd

    Olgierd Member

    Hi,
    I was able to use server to send email and authenticated with username and password under domain what was not active in configuration. I had only mailbox active and domain not active. By this way I was able to provide bulk email service for some customers and bounced messages went to different server. The reason to do this was that Microsoft 365 not allow send more emails than 30 per minute and some software for payroll need to send more then this limit.

    Now after ISPConfig update to 3.2.2 I have to activate domain in configuration. The do side of this that server is looking for mailboxes on the same server not external one, so if in the bulk email is an email address under the same domain server will not deliver those messages to external server.

    Is there a fix for it or some configuration trick ?
    Thanks,
    Olgierd
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You'll need to configure something locally, in the past the active setting wasn't respected everywhere, which was a bug you happened to rely on as an intended feature. To do so you'll need to create local conf-custom templates to make your changes in so they survive updates, I think you will need both mysql-virtual_sender_login_maps.cf and the dovecot-sql.conf template, which varies by OS (eg. for debian it is debian6_dovecot-sql.conf.master). Change them to remove the checks of mail_domain.active (see https://git.ispconfig.org/ispconfig/ispconfig3/-/commit/971427f312beae9e102b444c89b760f22f96518c and https://git.ispconfig.org/ispconfig/ispconfig3/-/commit/a26d4faef64372d536952819d893bbb4d1a251d9).
     

Share This Page