Allow only https://... :443?

Discussion in 'General' started by DrJohn, Jul 30, 2010.

  1. DrJohn

    DrJohn Member HowtoForge Supporter

    My RoundCube webmail site site is (at last) configured for ssl, but it still also responds to normal http web requests on port 80. How can I instead allow only https on 443 ?

    I'd like to enforce https for webmail access.

    Thanks
     
  2. sjau

    sjau Local Meanie Moderator

    remove port 980 from the ports.conf (I think) and from the vhost
     
  3. DrJohn

    DrJohn Member HowtoForge Supporter

    I believe that removing port 80 from /etc/apache2/ports.conf will disable port 80 globally. There are a bunch of other sites under ispconfig that use 80.

    However, experimentally I removed the <VirtualHost > ... </VirtualHost> declaration for this site on port 80 from Vhosts_ispconfig.conf, and it seems to work.

    I'll update if there's a problem.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. DrJohn

    DrJohn Member HowtoForge Supporter

    Thank you again Till,

    That solution works very well. I restored the original Vhosts file then added the rewrite directive in your link into ispconfig's Apache2 directive for the site.

    Now, sending the http address comes back as https, and only for this site. Very nice.

    -- John
     

Share This Page