All websites loading from the first website folder

Discussion in 'Installation/Configuration' started by Ralph W Trynor, Aug 8, 2020.

  1. Ralph W Trynor

    Ralph W Trynor New Member HowtoForge Supporter

    All websites loading from the first website folder even though when I FTP in it takes me to the correct folder like WEB1, WEB2, WEB3 and so on. But when I go to the site by name like Site1.com, site2.com, site3.com they all display the site1.com info. That is my first problem and I also have a problem where the SMTP-Server is offline and can not seem to get it going. I had the server running for years on another computer and decided to setup a fresh install on a new computer and add everything to it one at a time and this is what I ran into. I am using the latest Debiad and Ispconfig 3 and used the install instructions step by step to install. Any ideas as to what may be going on.
     

    Attached Files:

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Ralph W Trynor

    Ralph W Trynor New Member HowtoForge Supporter

    Thanks I had two problems. Some sites had * and some the IP number and then some had ssl on and some did not. Now I just need to figure out what the SMTP service is offline.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. Ralph W Trynor

    Ralph W Trynor New Member HowtoForge Supporter

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Debian GNU/Linux 10 (buster)

    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1dev


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 7.3.19-1~deb10u1

    ##### PORT CHECK #####

    [WARN] Port 25 (SMTP server) seems NOT to be listening
    [WARN] Port 25 (SMTP server) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "smtp" entry in your postfix master.cf

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 20944)
    [WARN] I could not determine which mail server is running.
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 428)
    [INFO] I found the following imap server(s):
    Dovecot (PID 428)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 731)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [anywhere]:110 (428/dovecot)
    [anywhere]:143 (428/dovecot)
    [anywhere]:465 (24705/master)
    [anywhere]:21 (731/pure-ftpd)
    ***.***.***.***:53 (455/named)
    [localhost]:53 (455/named)
    [anywhere]:22 (483/sshd)
    [localhost]:953 (455/named)
    [anywhere]:993 (428/dovecot)
    [anywhere]:995 (428/dovecot)
    [localhost]:10023 (553/postgrey)
    [localhost]:10024 (895/amavisd-new)
    [localhost]:10025 (24705/master)
    [localhost]:10026 (895/amavisd-new)
    [localhost]:10027 (24705/master)
    [anywhere]:587 (24705/master)
    [localhost]:11211 (433/memcached)
    [localhost]10 (428/dovecot)
    [localhost]43 (428/dovecot)
    *:*:*:*::*:8080 (20944/apache2)
    *:*:*:*::*:80 (20944/apache2)
    *:*:*:*::*:465 (24705/master)
    *:*:*:*::*:8081 (20944/apache2)
    *:*:*:*::*:21 (731/pure-ftpd)
    *:*:*:*::*:53 (455/named)
    *:*:*:*::*:22 (483/sshd)
    *:*:*:*::*:953 (455/named)
    *:*:*:*::*:443 (20944/apache2)
    *:*:*:*::*:993 (428/dovecot)
    *:*:*:*::*:995 (428/dovecot)
    *:*:*:*::*:10023 (553/postgrey)
    *:*:*:*::*:10024 (895/amavisd-new)
    *:*:*:*::*:3306 (1937/mysqld)
    *:*:*:*::*:10026 (895/amavisd-new)
    *:*:*:*::*:587 (24705/master)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    f2b-sshd tcp -- [anywhere]/0 [anywhere]/0 multiport dports 22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain f2b-sshd (1 references)
    target prot opt source destination
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with icmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with icmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with icmp-port-unreachable
    RETURN all -- [anywhere]/0 [anywhere]/0
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Check again the Postfix installation steps in the Perfect Server Guide, something seems to be wrong.
    Then try starting postfix, that may show error message why it does not start or provide other clues:
    Code:
    systemctl status postfix
    systemctl start postfix
     

Share This Page