All quotas showing as unlimited

Discussion in 'ISPConfig 3 Priority Support' started by rodti, Oct 29, 2013.

  1. rodti

    rodti Member

    I'm running ISPConfig 3.0.5.3 on two servers (one as a mirror), both of which have recently been upgraded to Wheezy.

    Quotas have worked as intended on this setup in the past.

    While updating templates I noticed that all quotas (web, mail, etc) are all showing in the overviews as unlimited. Usage is shown correctly.

    Quota appears to be working on both servers. The repquota command shows usage correctly but all hard and soft limits are shown as 0.

    The ISPConfig template and client pages show the limits correctly and these are also correct in the ISPConfig database.

    I've resynced everything and run the server.sh and cron_daily.sh scripts but all quotas still show as unlimited in the interface and in repquota.

    Any ideas? Really stumped by this one.

    Mods: Could you delete my original thread with the same title from ISPConfig3/General? Thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do the quotas show up corectly on the limits tab of the client in the client settings?
     
  3. rodti

    rodti Member

    Yep, and they're all correct in the corresponding DB table.

    For info I only have one mounted system volume so assuming /var/www sits comfortably within the / fstab.

    As I said it's worked before, seems to have gone awry recently, perhaps with the upgrade to Wheezy.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats strange as the dashlet gets the limit values from client table, its the same table were the client form gets the values from and the values are not stored anywere else. maybe there is something wrong with the myswl master/master replication? have you checked the replication state in mysql?
     
  5. rodti

    rodti Member

    No MySQL errors. The limit_ fields in the client DB tables are correct and consistent across master and slave servers.

    The limit tab in ISPConfig's client view has the correct data (as per the DB).

    The overview on ISPConfig's home page shows correct usage but all limits as unlimited for all sites.

    Repquota shows the same into, correct usage but 0 limits.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats strange, did not had this problem yet in a current relaese. You are logged in as client (not admin) and the ispconfig version is the current one (3.0.5.3)?
     
  7. rodti

    rodti Member

    Yep, 3.0.5.3.

    Logged in as client the account limits (mailboxes, domains etc) on the homepage are correct but soft and hard website hard disk quotas are unlimited. Used space shows correctly.

    Under 'Sites' / Website quota (harddisk) no data is displayed.
     
  8. rodti

    rodti Member

    Can I assume that the quota limits in the DB are pushed to quota on the file system using server.sh and/or cron_daily.sh?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    ah ok, then I miunderstood you. ISPConfig gets the quota values from the repquota command. The website quota is set in the filesystem when the website is created or when the quota value of a website is changed by server.sh script.
     
  10. rodti

    rodti Member

    So if the quota details are correct in ISPConfig then presumably this information isn't being sent to quota by server.sh or quota isn't functioning correctly.

    If for example I wanted to try and set one of the users manually to test it, how would I set a hard and soft limit for their HDD space?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The command to edit quotas on linux is named edquota, to show the quotas use the command repquota.
     
  12. rodti

    rodti Member

    OK, so I've used edquota to add a 5GB soft limit to one of the clients (at group level). They've currently used 4.5GB. Using repquota -avug shows the limit correctly:

    Code:
                            Block limits                File limits
    Group           used    soft    hard  grace    used  soft  hard  grace
    ----------------------------------------------------------------------
    client1   -- 4598484 5000000       0            172     0     0 
    However in the ISPConfig overview it still doesn't show:

    Code:
    Website Harddisk Quota
    Domain / Website	Used space	Soft limit	Hard limit
    domain.tld  4490.71 MB	unlimited	unlimited
    I've tried remounting the volume and running server.sh but nothing changes.

    Unfortunately the packages I offer my users are based on usage so this presents me with something of a problem!
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The values in ispconfig are not updated immediately. Please check again in an hour if the values are visible then.
     
  14. rodti

    rodti Member

    I made that change at 8am this morning :)
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, ok :) Maybe your server.sh process is not running or it fails for some reason. Please try the debug instructions at the end of this post:

    http://www.howtoforge.com/forums/showthread.php?t=58408

    the process that writes the quota info into the database is the same one that writes changes to disk, so if it fails, ispconfig is not able to read or write quota.
     
  16. rodti

    rodti Member

    Output from server.sh:

    Code:
    /sbin/mpt-status
    libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file '/lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep.bin'
    Failed to load mptctl
    /sbin/tw_cli
    
    Error: (CLI:003) Specified controller does not exist.
    
    /usr/bin/fail2ban-client
    /sbin/iptables
    /sbin/ip6tables
    finished.
     
  17. rodti

    rodti Member

    It's worth noting that running server.sh soon after that came through clean. I believe the libkmod issues are due to the customer kernel my dedicated server provider use.

    As before however quotas have historically worked on this server so I don't think that's the root cause.
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    This can be ignored indeed. Its not related to your issue. You see these errors because your provider uses some kind of generic images which has drivers and software for raid controllers installed which does not exist as hardwre on your system. The errors are shown when ispconfig tries to query these tools for the raid state.
     
  19. rodti

    rodti Member

    Is there anywhere else I should be checking for errors related to this issue? Everything looks fine but still not updating quotas!
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post your /etc/fstab file and the output of:

    repquota -avug

    you dont have to post the full repquta output, a few lines with web user and client gropus is enough.
     

Share This Page