all outgoing mails goes to directly spam folder

Discussion in 'General' started by icphedia, Mar 23, 2007.

  1. icphedia

    icphedia New Member

    Hi all,

    All outgoing mails goes to directly spam folders (junk, bulk, etc..) But if we reply any mails they goes to directly inboxes normally.

    Our all co-domains have this problem.

    Everything looking normally but we don't have any idea..
     
    Last edited: Mar 23, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

  3. icphedia

    icphedia New Member

    not listed blacklists.

    we have spf records, gmail said pass.. and we have reverse dns too. everything looking like normally. but we couldnt send mail..

    Code:
    Mar 26 08:40:37 server1 postfix/smtp[13991]: 94A9AA74063: to=<[email protected]>, relay=mx4.hotmail.com[65.54.244.232], delay=3, status=sent (250  <[email protected]> Queued mail for delivery)
    Mar 26 08:41:05 server1 postfix/smtp[13990]: connect to garanti-iplik.com.tr[192.168.0.2]: Connection timed out (port 25)
    Mar 26 08:41:05 server1 postfix/smtp[13990]: 94A9AA74063: to=<[email protected]>, relay=none, delay=31, status=deferred (connect to garanti-iplik.com.tr[192.168.0.2]: Connection timed out)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this server hosted on a dynamic IP?

    If not, contact garanti-iplik.com.tr and ask them why there server times out.
     
  5. icphedia

    icphedia New Member

    servers hosted on a static IP.

    garanti-iplik.com.tr our exchange server.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you able to connect to the exchange server from your linux server with telnet:

    telnet garanti-iplik.com.tr 25
     
  7. icphedia

    icphedia New Member

  8. icphedia

    icphedia New Member

    this is a spam mail.. :confused: :confused:


    Delivered-To: [email protected]
    Received: by 10.70.92.3 with SMTP id p3cs316367wxb;
    Mon, 26 Mar 2007 02:40:48 -0700 (PDT)
    Received: by 10.82.152.16 with SMTP id z16mr13388675bud.1174902047961;
    Mon, 26 Mar 2007 02:40:47 -0700 (PDT)
    Return-Path: <[email protected]>
    Received: from server1.garanti-host.net (Server1.garanti-host.net [88.249.244.28])
    by mx.google.com with ESMTP id g1si27339494muf.2007.03.26.02.40.47;
    Mon, 26 Mar 2007 02:40:47 -0700 (PDT)
    Received-SPF: pass (google.com: domain of [email protected] designates 88.249.244.28 as permitted sender)
    Received: from UebiMiau (localhost.localdomain [127.0.0.1])
    by server1.garanti-host.net (Postfix) with SMTP id 3040EA74063
    for <[email protected]>; Mon, 26 Mar 2007 12:40:14 +0300 (EEST)
    Received: from client 192.168.0.100 for UebiMiau2.7 (webmail client); Mon, 26 Mar 2007 12:40:14 +0100
    Date: Mon, 26 Mar 2007 12:40:14 +0100
    From: "admin" <[email protected]>
    To: [email protected]
    Reply-To: "admin" <[email protected]>
    Subject:
    X-Priority: 3
    X-Mailer: UebiMiau 2.7.2
    X-Original-IP: 192.168.0.100
    Content-Transfer-Encoding: 8bit
    X-MSMail-Priority: Medium
    Importance: Medium
    Content-Type: text/plain; charset="iso-8859-1";
    MIME-Version: 1.0
    Message-Id: <[email protected]>


    *********************************************************************************************

    Mar 26 12:50:36 server1 courierpop3login: LOGIN, user=web4_admin, ip=[::ffff:127.0.0.1]
    Mar 26 12:50:36 server1 courierpop3login: LOGOUT, user=web4_admin, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Mar 26 12:50:37 server1 postfix/smtp[20918]: setting up TLS connection to mail.defter.org
    Mar 26 12:50:37 server1 postfix/smtp[20918]: verify error:num=18:self signed certificate
    Mar 26 12:50:37 server1 postfix/smtp[20918]: Peer verification: CommonName in certificate does not match: plesk != mail.defter.org
    Mar 26 12:50:37 server1 postfix/smtp[20918]: Peer certificate could not be verified
    Mar 26 12:50:37 server1 postfix/smtp[20918]: 40109A74063: to=<[email protected]>, relay=mail.defter.org[91.191.168.87], delay=1, status=sent (250 ok 1174902355 qp 27196)
    Mar 26 12:50:37 server1 postfix/qmgr[20378]: 40109A74063: removed
     
    Last edited: Mar 26, 2007
  9. falko

    falko Super Moderator ISPConfig Developer

    Why does it say this?

    What's the output of
    Code:
    ifconfig
    on your server, and what's in /etc/hosts?
     
    Last edited: Mar 27, 2007
  10. icphedia

    icphedia New Member

    i solve connection time out problem. it just our local settings. :)

    We still have same problems about spam e-mails.
    Hotmail does not accept our e-mails in no way.
    When we send it to G-mail, e-mails drop into spam folder.
    When we send it to Yahoo, e-mails drop into bulk folder.



    Code:
    server1:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:14:22:0C:6E:BA
              inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::214:22ff:fe0c:6eba/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:161850 errors:0 dropped:0 overruns:0 frame:0
              TX packets:152463 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:29658779 (28.2 MiB)  TX bytes:60112786 (57.3 MiB)
              Interrupt:209
    
    eth0:0    Link encap:Ethernet  HWaddr 00:14:22:0C:6E:BA
              inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              Interrupt:209
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:39884 errors:0 dropped:0 overruns:0 frame:0
              TX packets:39884 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:14601095 (13.9 MiB)  TX bytes:14601095 (13.9 MiB)
    
    Code:
    server1:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost server1 server1.garanti-host.net
    192.168.0.100 server1.garanti-host.net server1
    88.249.244.28 server1.garanti-host.net server1
    192.168.0.101 virtual-ip1.garanti-host.net virtual-ip1
    
    
    # The following lines are desirable for IPv6 capable hosts
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
     
  11. edge

    edge Active Member Moderator

    You WILL need a valid SPF record for Hotmail and Gmail (and many more)

    I've emaild Hotmail about this some time ago.
    Here is a small quote of the reply
    Hotmail will also need to add your domain(s) to the "SenderID program" (see last part in the reply)

    More info at http://postmaster.live.com/Default.aspx
     
    Last edited: Mar 28, 2007
  12. icphedia

    icphedia New Member

  13. falko

    falko Super Moderator ISPConfig Developer

    You shouldn't use two IP addresses for the same hostname. Remove one of these lines.

    Also, does your server have a valid reverse DNS record?
     
  14. icphedia

    icphedia New Member

    thx falco, i removed 192.168.0.100 server1.garanti-host.net server1 one.


    Testing 88.249.244.28

    Test Name Result Details TTL Time
    PTR Pass PTR= server1.garanti-host.net. 86400 seconds 0 ms
     
  15. falko

    falko Super Moderator ISPConfig Developer

    If it still doesn't work, you should contact the Hotmail/GMail/... support and ask why your emails go to the spam folder.
     

Share This Page