All my websites are down and cant find whats wrong

Discussion in 'Server Operation' started by wachira, Nov 17, 2010.

  1. wachira

    wachira New Member

    I have a CentOS Server and i use ispconfig 3. I have hosted 10 websites and the other day all my websites went down. I have tried to look at the logs i cant see any thing ISPconfig logs dont have any errors. So am out of ideas can any one help me ?:confused:
     
  2. mini14

    mini14 New Member

    Got shell access?

    Log in through SSH and type service httpd restart and see if that cures it.

    Or... go into ISPC and check your services!
     
  3. wachira

    wachira New Member

    when I restarted httpd it restarts but has this error
    Starting httpd: [Wed Nov 17 22:03:55 2010] [error] (EAI 2)Name or service not known: Could not resolve host name *: -- ignoring!
    [Wed Nov 17 22:03:55 2010] [warn] NameVirtualHost 192.XXXX:443 has no VirtualHosts
     
  4. mini14

    mini14 New Member

    Hmm.. do you have physical access to this server or is it in some remote data center?

    If you have physical access I'd take it offline and plug in a monitor and keyboard and see what's up.
     
  5. wachira

    wachira New Member

    I have the server with me so I have been trying to figure out what might have gone wrong. Any one with any idea let me know.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log?
     
  7. wachira

    wachira New Member

    Actually I noticed that its my IP address that changed. I will tell cron job to be checking my Ip address if it changs to send me an email. Thanx Guys for the help:)
     
  8. mini14

    mini14 New Member

    That'll do it every time ;)

    Glad you found it was something simple instead of a major issue.

    BTW.. I don't know about your ISP but mine only charges a few dollars more per month for a fixed IP number. My high traffic servers are of course in a local colo/data center but I do run one low traffic webserver from home on a 10 mps line from my ISP (local cable company) and it has a fixed IP.
     

Share This Page