All mail stays in ACTIVE queue

Discussion in 'Server Operation' started by jariasca, Apr 8, 2010.

  1. jariasca

    jariasca Member

    Hi all,
    since I make an update yesterday to the server all email goes to the active queue and takes about 10 min or never guest to the mailbox (in or out)
    and I'm havinf the error msg (!)ClamAV-clamd: Can't connect to UNIX socket /tmp/clamd.socket: No such file or directory, retrying (2)

    can someone help me

    Jorge

    Apr 8 15:00:18 mail postfix/qmgr[26650]: 509B818D01DD: removed
    Apr 8 15:00:18 mail couriertcpd: Connection, ip=[::ffff:201.199.133.118]
    Apr 8 15:00:18 mail couriertcpd: LOGIN, [email protected], ip=[::ffff:201.199.133.118], port=[40602]
    Apr 8 15:00:19 mail amavis[26582]: (26582-04-10) (!)ClamAV-clamd: Can't connect to UNIX socket /tmp/clamd.socket: No such file or directory, retrying (2)
    Apr 8 15:00:19 mail postfix/smtpd[26789]: connect from OL132-122.fibertel.com.ar[24.232.122.132]
    Apr 8 15:00:20 mail postfix/smtpd[26789]: NOQUEUE: reject: RCPT from OL132-122.fibertel.com.ar[24.232.122.132]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in virtual mailbox table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<com.ar>
    Apr 8 15:00:21 mail postfix/smtpd[26789]: disconnect from OL132-122.fibertel.com.ar[24.232.122.132]
    Apr 8 21:00:21 mail postfix/smtpd[26769]: 3B93718D01BD: client=unknown[127.0.0.1]
    Apr 8 15:00:21 mail postfix/cleanup[26776]: 3B93718D01BD: message-id=<[email protected]>
    Apr 8 15:00:21 mail postfix/qmgr[26650]: 3B93718D01BD: from=<[email protected]>, size=3248, nrcpt=1 (queue active)
    Apr 8 15:00:21 mail amavis[26583]: (26583-03-9) Passed SPAM, [190.179.178.54] [190.179.178.54] <[email protected]> -> <[email protected]>, quarantine: spam-LSuS2aO6sOj1.gz, Message-ID: <[email protected]>, mail_id: LSuS2aO6sOj1, Hits: 16.727, size: 2767, queued_as: 3B93718D01BD, 26559 ms
    Apr 8 21:00:21 mail postfix/smtp[26748]: 6593E18D01BE: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, conn_use=9, delay=294, delays=1.3/266/0/27, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=26583-03-9, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3B93718D01BD)
    Apr 8 15:00:21 mail postfix/qmgr[26650]: 6593E18D01BE: removed
    Apr 8 15:00:21 mail postfix/pipe[26829]: 3B93718D01BD: to=<[email protected]>, relay=maildrop, delay=0.04, delays=0.02/0/0/0.02, dsn=2.0.0, status=sent (delivered via maildrop service)
    Apr 8 15:00:21 mail postfix/qmgr[26650]: 3B93718D01BD: removed
     
  2. Mark_NL

    Mark_NL New Member

    1. Which distro are you running?
    2. Check where clamav is creating the socket file with:
    Code:
    grep LocalSocket /etc/clamav/clamd.conf
    3. Check where amavis is expecting the socket file to be:
    in the amavis config tree (/etc/amavis) there should be a file "15-av_scanners" open it, and check the part of ClamAv, it should look something like this:
    Code:
    ['ClamAV-clamd',
       \&ask_daemon, ["CONTSCAN {}\n", "[B]/var/run/clamav/clamd.ctl[/B]"],
       qr/\bOK$/, qr/\bFOUND$/,
       qr/^.*?: (?!Infected Archive)(.*) FOUND$/ ],
    the bold part has to be the same in both config files.
     
  3. jariasca

    jariasca Member

    Thanks for the response

    I'm using centos 5.4

    [[email protected] etc]# grep LocalSocket /etc/clamd.conf
    #LocalSocket /tmp/clamd.socket
    #LocalSocketGroup virusgroup
    #LocalSocketMode 660

    [[email protected] clamav]# cd /var/run/clamav
    [[email protected] clamav]# ls
    clamd.pid

    I don't have a 15-av_scanners

    [email protected] etc]# find / -name 15-av_scanners
    [[email protected] etc]#

    please advise
     
  4. Mark_NL

    Mark_NL New Member

    uncomment the localsocket lines in /etc/clamd.conf ..

    i think you should then be fine.
     

Share This Page