all incoming mail not getting spam score/headers

Discussion in 'ISPConfig 3 Priority Support' started by wokka, May 21, 2014.

  1. wokka

    wokka New Member HowtoForge Supporter

    I used the 14.04 apache perfect server setup, for the most part, not many customizations have been done. I did install opendkim and configure it, and it's working as expected, but I'm just marking emails as they go out, I'm not filtering on incoming for DKIM sigs. I also added checks for valid domains, added use of RBL's, etc, per a guide on here.

    Some emails inbound are getting marked with the X-Spam header, some are not, here is one that is marked: https://gist.github.com/wokka1/9884661529aa94e059ee
    And one that is not: https://gist.github.com/wokka1/f518f0540e5bdc102727

    Here is the mail.log entry for the email that didn't have markings: https://gist.github.com/wokka1/66166fa077ffd53025cf

    Here is my main.cf: https://gist.github.com/wokka1/76f0a1ba191c842580ec
    master.cf: https://gist.github.com/wokka1/42b7b1fcfbde0a65eeb5
    amavis 50-user: https://gist.github.com/wokka1/ac95c9d8cccfcaab91f4
    Relevant amavis debug logs: https://gist.github.com/wokka1/2f5b652cac61a4b5be6d Please note, these debug logs were from a test message, not the original spam. I can recreate the no spam headers by sending an email from my work domain (exchange) into my ispconfig setup. The exchange server email is coming across the internet.

    I'm at a loss as to why some are not being marked with spam headers. The amavis debug logs give great detail, I'm just not sure exactly what I'm looking for there.

    Thanks for your help and let me know if you need further info please.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Ensure that you enabled the spamfilter for the mailbox or email domain.
    2) A mail gets a spam score when the spamassasin filter rules (amavis uses spamassasin internally) apply a score to them. Such filter rules will never hit 100% of the emails, so it can be that a spam mail gets no score as it takes some weeks until the bayes filter of amavis are fully trained.
    3) If you send email from your own exchange server or route it trough the exchange server instead of receiving the email over the internet, then a much lower or no score will be applied to the email.
     
  3. wokka

    wokka New Member HowtoForge Supporter

    Thanks Till.

    Even if Amavis has a 0 or negative score, it should note that in the headers, yes?

    The Exchange server is a different domain and routing smtp over the internet, my emails coming from it should have a low score (most are -1). I just can't figure out how some obvious spam is coming in with no spam headers. I'll have to find some known spam that didn't get spam headers and find that in the amavis debugs.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Amavis will add the score only when it exceeds the spam tag level 1. If you want t see all headers, set the spam tag level 1 to e.g. -100.

    There are 2 tag levels: the spam tag level 1 is the one that defines the score to add infos in the header and the spam tag level 2 is the score taht defines when a email is actually spam.

    As howtoforge subscriber, you can download the ispconfig manual here;

    http://www.howtoforge.com/download-the-ispconfig-3-manual

    the scores and other policy settings are described there in detail.
     
  5. wokka

    wokka New Member HowtoForge Supporter

    Ah, thank you for the explanation, I do have the manual, but I didn't understand the relevance of the first tag level. I'm modifying my policies now so that I can see all of the spam scores.

    Thanks!
     
  6. wokka

    wokka New Member HowtoForge Supporter

    Thanks again Till, that was my problem, I needed to set tag level 1 to a lower number.
     

Share This Page