all incoming email gets dumped into /root/maildir

Discussion in 'Installation/Configuration' started by emdok, Feb 20, 2009.

  1. emdok

    emdok New Member

    I'm having an issue with incoming mail. It isn't going to the user's mailbox. I think mail destined for a domain is to go to /var/www/<website>/mail or maildir? Instead I see it all in /root/maildir/new

    I had followed the perfect server setup for centos 5.2. I started with 2.2.28 then upgraded to 2.2.29 last month. I've only used it for website hosting, just starting to use it for email also

    Do I have a configuration error somewhere? Where do I start to troubleshoot?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please remove the unneeded aliases from the /etc/aliases file and then rebuild the database with the command newaliases.
  3. emdok

    emdok New Member

    I didn't see any entries that looked unneeded. I'm not sure what's needed and what's not though.
    Ran newaliases anyway:
    /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
    Would you like me to post the aliases file?

    I see in the settings tab for email /etc/postfix/virtusertable
    When I look at that file I see entries such as:
    [email][email protected][/email]    web13_info
    [email][email protected][/email]    web13_info
    I was trying to make [email protected]
    Is there supposed to be the www before the domain name?
    When I created the new site I left the www in the Hostname field then typed the domain name below it. Even if I send email to [email protected] it doesn't go into the correct mailbox.

    Also, I'm not using ISPConfig for dns, I have an mx record setup under the domain providers dns that points to my ISPConfig box. I can confirm that mail is being delivered to it as it all appears in /root/maildir

    Is there something else I should check?

    Much Thanks in advance.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You missed to add a co-domain to the website
  5. emdok

    emdok New Member

    wow indeed I did!! It works now.

    Thanks very much Till.

Share This Page