all http off after ispconfig update on jessie php-fpm

Discussion in 'Installation/Configuration' started by kmchen, Dec 21, 2016.

  1. kmchen

    kmchen New Member

    Hi,

    After a Jessie upgrade and php-fpm implementation I discovered ispconfig was not working anymore.
    How can I make ispconfig work with php5-fpm through tcp conection like that:
    Code:
    ProxyPassMatch ^/(.*\.php)$ fcgi://127.0.0.1:9001/var/www/example.com/web/$1
     
    Last edited: Dec 21, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The directive you posted is not used on Debian Jessie servers for php-fpm. Ensure that you installed and enabled mod_fastcgi in apache (not to mix up with mod_fcgi). Then resart apache.
     
  3. kmchen

    kmchen New Member

    Thanks for your reply
    What do you mean ? It works for several websites on that Debian Jessie server

    About fastcgi here is my config:
    But I see a ispconfig in sites available that seems unused:
     
    Last edited: Dec 22, 2016
  4. kmchen

    kmchen New Member

    Please, about my php-fpm on apache 2.4 configuration, have a look at
    https://www.vincentliefooghe.net/content/configuration-apache-24-php-fpm for tsp connection use on apache 2.4 and php-fpm.

    About ISPCONFIG, I launched ispconfig_update.sh and I think I have ispconfig 3.1 installed now.

    But when I try to enable site ISPCONFIG I get that:
    How can I verify that ISPCONFIG is proprely installed ?
     
    Last edited: Dec 28, 2016

Share This Page