All emails to [email protected] undeliverable

Discussion in 'Server Operation' started by TheMaximumWeasel, Jul 27, 2007.

  1. TheMaximumWeasel

    TheMaximumWeasel New Member

    I keep getting these emails:
    Return-Path: <>
    X-Spam-Checker-Version: SpamAssassin 3.2.1 (2007-05-02) on maxweisel.com
    X-Spam-Level:
    X-Spam-Status: No, score=0.0 required=5.0 tests=none autolearn=ham
    version=3.2.1
    X-Original-To: [email protected]
    Delivered-To: [email protected]
    Received: from rwcrmhc13.comcast.net (rwcrmhc13.comcast.net [216.148.227.153])
    by maxweisel.com (Postfix) with ESMTP id 7BB7A18A815E
    for <[email protected]>; Fri, 27 Jul 2007 01:29:01 -0700 (MST)
    Received: from rwcrmhc13.comcast.net (localhost[127.0.0.1])
    by comcast.net (rwcrmhc13) with ESMTP
    id <20070727082901m13005lftfe>; Fri, 27 Jul 2007 08:29:01 +0000
    From: Mail Delivery Subsystem <[email protected]>
    Subject: Returned mail: delivery problems encountered
    Message-Id: <[email protected]>
    Date: 27 Jul 2007 8:13:58 +0000
    To: <[email protected]>
    Mime-Version: 1.0
    Content-Type: multipart/report; report-type=delivery-status; boundary="_46a9a946.69ed.0+comcast.net=_"
    X-Virus-Status: No
    X-Virus-Checker-Version: clamassassin 1.2.4 with clamscan / ClamAV 0.91.1/3779/Thu Jul 26 12:33:22 2007

    --_46a9a946.69ed.0+comcast.net=_
    Content-Type: text/plain

    A message (from <[email protected]>) was received at 25 Jul 2007 2:41:34 +0000.

    The following addresses had delivery problems:

    [email protected]
    Persistent Transient Failure: Delivery time expired
    Delivery last attempted at 25 Jul 2007 2:41:34 +0000

    --_46a9a946.69ed.0+comcast.net=_
    Content-Type: message/delivery-status

    Reporting-MTA: dns; comcast.net
    Arrival-Date: 25 Jul 2007 2:41:34 +0000

    Final-Recipient: rfc822; [email protected]
    Action: failed
    Status: 4.4.7 Unable to contact host for 2 days,
    Diagnostic-Code: smtp; Persistent Transient Failure: Delivery time expired
    Last-Attempt-Date: 25 Jul 2007 2:41:34 +0000

    --_46a9a946.69ed.0+comcast.net=_
    Content-Type: message/rfc822

    Received: from maxweisel.com ([69.252.140.253])
    by comcast.net (rwcrmhc13) with ESMTP
    id <20070725024134m13006qqr0e>; Wed, 25 Jul 2007 02:41:34 +0000
    Received: from maxweisel.com (maxweisel.com [127.0.0.1])
    (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
    (No client certificate requested)
    by maxweisel.com (Postfix) with ESMTP id 9A5DB18A816B
    for <[email protected]>; Tue, 24 Jul 2007 19:41:33 -0700 (MST)
    Received: (from [email protected])
    by maxweisel.com (8.13.8/8.13.8/Submit) id l6P2fXA1003887
    for [email protected]ldomain; Tue, 24 Jul 2007 19:41:33 -0700
    Date: Tue, 24 Jul 2007 19:41:33 -0700
    From: Max Weisel <[email protected]>
    Message-Id: <[email protected]>
    X-Loop: [email protected]ldomain
    Subject: Mailsize: web1_max
    To: undisclosed-recipients:;

    955


    --_46a9a946.69ed.0+comcast.net=_--

    And I am getting these from comcast because I have comcasts smtp server set as my relayhost. So basically the problem is my server doesn't see localhost.localdomain as my server.

    Max
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure why it says localhost.localdomain.com (should be localhost.localdomain instead), but you can add localhost.localdomain.com to the end of /etc/postfix/local-host-names and restart Postfix.
     
  3. TheMaximumWeasel

    TheMaximumWeasel New Member

    I think when comcast gets the email to localhost.localdomain it adds .com to it because it probably thinks the user forgot to add .com or .net or whatevere it was. One thing that I know is my server doesn't see itself as being localhost.localdomain even though in my /etc/hosts files localhost.localdomain points to localhost

    Max
     
  4. TheMaximumWeasel

    TheMaximumWeasel New Member

    I figured out exactly whats wrong now how do I fix it?

    I think I know what the problem is. When I installed Centos 5 by using the perfect set-up guide. I set-up MailDIR's then not liking how it was running later on I removed the two lines from postfix's main.cf and unchecked the maildir option in ispconfig. After that I got this same error message for all previously created mail users. How I solved it was to edit each mail user and then save it in ispconfig and ispconfig fixed everything. I guess admispconfig is still set for using maildir's how do I fix it.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    There'S nothing you must fix. admispconfig always uses Maildir, regardless of what other users use.
    Please try what I suggested above.
     
  6. TheMaximumWeasel

    TheMaximumWeasel New Member

    I am trying your solution now. I only get these emails late at night so tomorrow morning I will have a look. I switched all of my email accounts over to Maildir. I have some old /var/spool/mail files from a previous server and would like to know how I can convert them from mbox to maildir.

    Max

    I still can't figure out mb2md
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What problems do you have with mb2md?
     
  8. TheMaximumWeasel

    TheMaximumWeasel New Member

    I added localhost.localdomain.com to that list and I still get those undeliverable emails every morning. Any other Ideas??

    Max
     
  9. TheMaximumWeasel

    TheMaximumWeasel New Member

    I think ISPConfig removed localhost.localdomain.com before all of the undeliverable emails were sent out because I just checked the localhost names file for postfix and it wasn't there.

    Max
     
  10. TheMaximumWeasel

    TheMaximumWeasel New Member

    Also All of the undeliverable messages are coming from comcast. So I think my server relays all of the email statistics messages to comcast. Comcast then tries to deliver them then sends them back to me. So I think each set of undeliverable messages are two days old because comcast says it tried to deliver these messages for two days before it sent them back.

    Max
     
  11. TheMaximumWeasel

    TheMaximumWeasel New Member

    and when my server sends out these emails to comcast it sends them as localhost.localdomain. Comcast is adding the .com

    Max
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Did you add localhost.localdomain.com at the end of /etc/postfix/local-host-names (below the line #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####)?
     

Share This Page