All domains lead to main domain, argh!

Discussion in 'General' started by smokinjo, Feb 4, 2016.

  1. smokinjo

    smokinjo Member


    I am hit with a seemingly bizarre problem.

    A domain on my server ( I have 4-5 or five of them), is directed to the main initial domain.
    domain1 works fine
    domain2 always resolves as domain1

    I have changed nothing on the server in the past months, so this is seemingly coming form no where.

    AS well, theg other sites on my server temporarily stopped resolving to the right domain, but now work. But, all names/passwords are broken. Before fixing the domain resolving issue by rebooting the server, all password resets seemed to be settled by domain1.

    Now, they just have issues logging in to the website

    I should note that I am using Word Press for the sites.

    I rebooted the server to see if ti was a simple glitch. No luck.

    Thanks for any ideas!

    Last edited: Feb 4, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure that you dont mix IP address and * settings in websites. Set all sites to either * or to the IP address.
  3. Elayne

    Elayne Member

    Also don't forget to check them manually in the console of your OS. Check every vhost in /etc/apache2/sites-enabled/ files for any case. I've had such a problem with a previous panel before i migrate to ISPConfig which was configured to work for one exact IP address and when I needed a little reconfiguration, it turned out to be a disaster. Also be aware that SEO optimization might break up for a week if you noticed this in less than 24 hours after the configuration broke.

Share This Page