Aliases for email piping

Discussion in 'Installation/Configuration' started by ajw_doc, Jul 25, 2008.

  1. ajw_doc

    ajw_doc New Member

    I run a couple of sites that both have the need for email to be piped. I have one already set up in the etc/aliases file which works fine but my stumbling block is setting up the second site. Both sites use support and sales but etc/aliases only allows you to put in one support/sales alias (you dont reference the domain).

    I assume this is because there is only the one etc/aliases rather than one per site?

    Is there a way to achieve what I want?


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please remove the aliases from the file as this is the wrong way to set this up.

    Instead, enter the aliases in the aliases field of the mail account in ispconfig.
  3. ajw_doc

    ajw_doc New Member

    The alias is a php path to file command that doesn't work in the alias box as that is for setting up aliases to an existing user.

    Eg user is fred and alias is support. Support email will be sent to fred.

    I have a path to a php file that I need to send the email too.
    Last edited: Jul 25, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you describe in more detail what you're trying to do?
  5. ajw_doc

    ajw_doc New Member

    Hi Falko,

    I'm trying to pipe email into a support desk

    Eg mail to [email protected] > sent to php pipe file (pipe.php) > imported into helpdesk software (eg cerbeurs or kayako).

    I don't want to use the pop3 import method - I don't like it and it doesn't work for me.

    Now normally to do this and on other servers running other control panels I edit the alias file and add

    support: | php -q /path/to/pipe.php

    and all is good.

    However I can't do so here as there is only one aliases file for the server rather than one for each site so that limits me too only having one support email address being piped. I suspect only having one aliases file has something to do with the way ISPconfig has everything set up.

    I've tried using (user name) but to no avail!

    Obviously because I'm trying to send an email to a php file I can't use the alias box till suggested (I have tried that and the forward box and no joy).

    Last edited: Jul 26, 2008
  6. ajw_doc

    ajw_doc New Member

    To add, if there is something in ISPconfig I can edit to make an alias file for each site I'm happy to delve into the code!
  7. falko

    falko Super Moderator ISPConfig Developer

    I'd simply create a support email address for each site and then use the username of the account (e.g. web1_support) in /etc/aliases:

    web1_support: | php -q /path/to/pipe.php
  8. ajw_doc

    ajw_doc New Member

    Thanks Falko that works a treat! I had tried using the username but it wasn't working but tried again today and all is good!

    Thanks so much.


Share This Page