AliasDomain for Website on nginx

Discussion in 'Installation/Configuration' started by jackl, Feb 20, 2012.

  1. jackl

    jackl New Member

    Hi There!

    I'm trying to use Aliasdomain for website in ISPConfig 3 on nginx and it's working fine except for one thing, it is adding $1 to the end of the Redirect Path and that is messing up the URL and I'm getting 404 or 500 error. I'm just wondering if there is a work around.

    By the way, I'm using it for wiildcard:​

    will be redirected to:

    but using the Aliasdomain for website feature creates this:

    I am using Joomla 2.5.1 with SEF turned on by the way. Till or anybody, do you know a work around with what I'm trying to do?


  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. jackl

    jackl New Member


    Till, can you guide me where do I find the php file that creates the nginx .conf directives. :D desperately I just needed this wildcard feature for our communications team to do it by themselves, if this is not too tedious to modify everytime a new ISPConfig version comes out I would rather hack the code. I would just like to remove the $1 it added to the redirect path and everything should work as I want it to be.

    Oh, and a question, why does the script add $1 to the end of the rewrite nginx directive by the way? Nginx supposed to know what index file to load regardless it is specified or not.

    Big thanks Till!
  4. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker. I'll check it.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The $1 is to rewrite to the same path, it is not related to the index file.

    Thats not nescessary, as this can all be configured in the nginx_vhost.conf.master template. So you can configure it on your server as you need it and it wont get overwritten on updates when you put the modified configuration file in the conf-custom folder.

Share This Page