aliasdomain doesn't redirect

Discussion in 'Installation/Configuration' started by staatslot, Sep 12, 2010.

  1. staatslot

    staatslot New Member HowtoForge Supporter

    Hi all,

    This is the situation:
    I have www.website1.com and www.website2.com
    www.website1.com is installed as a website, so it has a folder on the server and everything works fine.

    I want www.website2.com to redirect into a subfolder of www.website1.com.
    Lets say the subfolder is called test.

    I added a aliasdomain with this information:
    domain: website2.com
    parent website: website1.com
    Redirect type R
    redirect path /test/
    auto subdomain *.
    Active: checked

    But when i visit www.website2.com I just get the root of www.website1.com.
    The addressbar is displaying website2.com.

    I changed the flag, I even tried to redirect to www.differentsite.com but it allways goes to the root of www.website1.com.

    Can anyone please help?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Use redirect type "noflag". If I remember correctly, the redirect will only work for the domain that you specified and not * wildcards. So your redirect will work for website2.com but not www.website2.com.

    If a domain shall have its own folder, then it is recommended to create a new website and not a aliasdomain.
     
  3. staatslot

    staatslot New Member HowtoForge Supporter

    Thanks, that cleared something up.
    I works just as long as I don't use the * for automatic subdomain.
    I prefer the * so all subdomains are being redirected, but i'm glad this works for now!
     

Share This Page