AliasDomain ... DNS

Discussion in 'ISPConfig 3 Priority Support' started by NeonTigerUK, Oct 14, 2017.

  1. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    Hi All,

    sorry for the stupid question, as I'm sure thats what this will be :eek:

    I have domain1.com, domain1.co.uk, domain2.com all pointing to my ISPConfig DNS. All 3 sites need to point at domain1.com

    Domain1.com has DNS record but neither of the others do (yet). domain1.co.uk and domain2.com are set up as aliasdomains pointing at domain1.com

    Do I need to have DNS records for the other sites? if so, which records should be present in the field set? only being there for web, I suspect its NS only but can someone please clarify

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Any domain that shall be accessible over the internet needs DNS records, otherwise the web browsers of your visitors will not find the IP of your server. If a domain is an alias domain of another website does not matter for DNS. You have to setup a full dns zone for each domain as you did for domain1.
     
  3. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    Hi Till,
    Thanks for confirming my dumbassery :) although I did check the manual and didn't see it, maybe worth adding a mention in the aliasdomains section.

    I saw the message on ISPC about the new version of the manual by the way, but the version for me to download was the old version - is the new version out yet?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not specific to alias domains. Any domain that you want to use for whatever reason has to exist in dns.

    The message in ISPConfig 3.1.7 says that you get the current manual when you do a donation, there is no message about a new version of the manual. We make a new version of the manual for each major release and the next major release is ISPConfig 3.2.
     
  5. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    ahh ok, probably me mis reading the message then
     

Share This Page