Alias outside of Web1?

Discussion in 'Installation/Configuration' started by Bedevere, Sep 4, 2005.

  1. Bedevere

    Bedevere New Member

    I upgraded to a new server and rebuilt form scratch. Using SuSE 9.2 and the latest ISPConfig (1.0.8?). I love the product, works great. One minor issue has me snagged though.

    This worked on my old server but won't now:

    I have a few directories I like to upload to via Samba, and they have been shared to my web sites via an alias command. One web site (lets say web2) has a share located outside it's folders and one which points to the user directory - I added this in the site setup:

    Code:
    Alias /user1 /srv/www/htdocs/web2/user/web1_user1/web
    Alias /files /srv/shared/Sambafiles
    <Directory '/srv/shared/Sambafiles'>
     Options +Indexes
     AllowOverride None
     Order allow,deny
     Allow from all
    </Directory>
    
    These are hypothetical paths but represent basically what I am doing. SAMBA shares out the Sambafiles directory for me over my lan. I generally do not allow index but I was doing it for testing purposes.

    For some reason my alias commands to the user directory works fine but the one to "/files" isn't at all. I get a 403 error. So I tested things by chmod the directory to 777 and even made the owner and group the same as the web folders in /srv/www/htdocs/web1/web.

    No good.

    To test things out I moved the Sambafiles directory to /srv/www/htdocs/web2/web and then set things as follows:

    Code:
    Alias /user1 /srv/www/htdocs/web2/user/web1_user1/web
    Alias /files /srv/www/htdocs/web2/web/Sambafiles
    <Directory '/srv/www/htdocs/web2/web/Sambafiles'>
     Options +Indexes
     AllowOverride None
     Order allow,deny
     Allow from all
    </Directory>
    
    Worked fine, I saw an index of the directory which shows that aliasing and directory commands do work, but somehow I cannot get out of the web site's storage location. Unfortunatly this won't work for me as the data is shared by multiple sites and needs to be readable by them...

    Any ideas? You guys are usually very fast and know whats going on, so I am pretty hopeful!
    :D
     
  2. till

    till Super Moderator

    Have you tried to use symlinks instaed of aliases? To enable Symlinks, add this to your vhost:

    Options +FollowSymlinks
     
  3. Bedevere

    Bedevere New Member

    Doh! Yes!

    I wil try this and report back.
     
  4. Bedevere

    Bedevere New Member

    Worked perfect. Thanks for reminding me about that option!
     

Share This Page