alias for phpmyadmin

Discussion in 'Installation/Configuration' started by tfboy, Aug 18, 2021.

  1. tfboy

    tfboy Member

    For some reason, I did not have phpmyadmin available - 404 error.
    Is it as simple as adding an alias to it in the site's configuration file? I don't remember doing this on my previous ISPconfig install and wondered if it shouldn't have been added automatically.
    Have I missed something?
    If I add the alias in the vhost file, it works, but I'm concerned I might break something elsewhere.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you installed PHPMyAdmin?
    How did you install ISPConfig? The autoinstall script does install PHPMyAdmin and the Guide has instructions on installing PHPMyAdmin.
     
  3. tfboy

    tfboy Member

    I did install - followed the perfect server guide for ISPconfig Ubuntu 20 with apache.
    I then migrated from a previous install using the migration tool.
    I did have phpmyadmin on my previous server and it's installed on the new one, just no alias to reach it.
    I tried adding the alias to my main vhost but I guess that will probably be deleted if ISPconfig rewrites the file.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    How are you trying to reach PHPMyAdmin?
     
  5. tfboy

    tfboy Member

  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  7. tfboy

    tfboy Member

    Yes, but only because I manually added an alias in the .vhost file.
    Shouldn't ISPconfig create the alias automatically? I don't remember having to do it manually on my previous server.
    If it is an automatic thing that wasn't done, I'm worried my manually corrected file will be overwritten by the automatic processes.
     
  8. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    No, phpmyadmin is setup by the autoinstaller or by following a perfect server guide, I would guess you missed a step when following the guide, or possibly the guide needs updated (things change upstream at times, requiring occasional updates).
    Perhaps you had the alias setup from a package you installed there, and installed differently on the current server.
    It will be. (For what it's worth, you can make update-safe changes via a conf-custom file, but that is probably not the best/correct solution for this case.)
     
  9. tfboy

    tfboy Member

    Strange, I followed the guide and pretty sure I didn't miss a step. The files were there (so the apt install process completed).
    Maybe I should re-run the ISPconfig installer ? For the record, I'm running Ubuntu 20.04.2 LTS with ISPConfig 3.2.5
     
  10. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    No, the installer doesn't configure phpmyadmin (though the autoinstaller does).

    Try 'dpkg-reconfigure phpmyadmin', select apache2 and hit OK.
     
  11. tfboy

    tfboy Member

    Thanks Jesse. I've done that:
    Code:
    # dpkg-reconfigure phpmyadmin
    Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
    dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf
    dbconfig-common: flushing administrative password
    apache2_invoke: Enable configuration phpmyadmin
    It appears to have fixed something. I've now removed the alias from my vhost file and reloaded apache2 and it still works :)
    Do you know where the link is made? I mean in which config file?
     
  12. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    'grep -R phpmyadmin /etc/apache2/' .. probably conf-available/phpmyadmin.conf.
     
    tfboy likes this.

Share This Page