Ahh, beloved postfix

Discussion in 'Installation/Configuration' started by norbie, Jul 27, 2012.

  1. norbie

    norbie New Member

    Hi,
    here is brain teaser. I had followed Falko's Howto and installed Ubuntu 12.04 LTS with Mail, Web etc. After I was done, everything worked just fine. In particular, the e-mail worked to my surprise. However, I have multiple Computer and I thought that it might be a good idea to hook them all together to one Administrative Site. I went ahead cleared the, working perfectly, install and re-installed the 12.04 LTS with the whole 9 yards, however did setup ISPConfig for multiple server. Everything appears to work fine, except after I did sent a test e-mail to my account with the ISP. There was no error and it seemed that the message went out but it never made it into my mailbox?

    After a little digging around, I found in the mail log that the recipient e-mail server timed out.

    All necessary ports are open on my side. The ISP allows me to open their Firewall at Port 25, so thats not an issue. I checked the blacklist, since it is possible that some heisted the system faster than I could send a test message. Nope, no blacklist entires found...
    I went probably three times over the installation and setup process, which turns out to be exactly as shown.
    Of course the things that happen behind closed doors are Greek to me!!!!
    I can send mails between the individual domains using the localhost from the console and I can receive only outside mails, but can't get anything away from my server anymore.

    Code:
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    23E081560AE8 1248 Tue Jul 24 00:10:56 [email protected]
    (connect to aspmx4.googlemail.com[xxx.xxx.xxx.xxx]:25: Connection timed out)
    [email protected]
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    23E081560AE8 1248 Tue Jul 24 00:10:56 [email protected]
    (connect to aspmx4.googlemail.com[xxx.xxx.xxx.xxx]:25: Connection timed out)
    [email protected]
    
    342181560DBC 2881 Sun Jul 22 21:45:11 [email protected]
    (connect to aspmx2.googlemail.com[xxx.xxx.xxx.xxx]:25: Connection timed out)
    [email protected]
    
    337631560AE2 1125 Mon Jul 23 10:55:41 [email protected]
    (connect to mx.east.cox.net[xxx.xxx.xxx.xxx]:25: Connection timed out)
    [email protected]
    
    Name modified excerpt from ISPConfigs Mail Queue.

    I have absolutely no idea what went wrong and starting to hallucinate that the new install dug up data from the previous one????

    Cheers,
    Norbert

     
    Last edited: Jul 28, 2012
  2. Mark_NL

    Mark_NL New Member

    Nowadays, a lot of ISP's block the usage of different SMTP servers except their own. Some still allow you to use submission (port 587). You could set their servers as relay server to fix it as well.
     
  3. norbie

    norbie New Member

    Postfix

    Hi Mark_NL,
    I still don't know why the port was suddenly closed. I have been with this ISP for years and been using PORT 25 without problems.
    They still let me either bypass or block this port, although it is somewhat confusing as to if the box should be checked or not. They also let me disable their firewall. :) This I can do via web interface, great service from their end. I am running a piece of software that uses the Ports 5200, 5189 and 5190 to communicate with an other network.
    I suppose when the firewall is disabled and the port 25 box is unchecked, it is open. That's the way it is right now and mail is working on one domain. The other two domains don't know how to receive and relay since I wan't them to wind up on one physical server. Actually, the foreing MTA gets a connection refused or timeout.
    In the contrary, I haven't set up a full blown mail server on the other domains.
    There is still a lot of work to be done!!!
    I might open another thread on that.
    In any case thank you for your reply.
    Cheers,
    Norbert
     

Share This Page