AHCI in Fedora Core 6

Discussion in 'Technical' started by juan.villa, Jan 21, 2007.

  1. juan.villa

    juan.villa New Member

    Hi. I have an intel DG965WH motherboard with an Intel Core 2 Duo 2.16ghz and a Segate Barracuda 7200RPM 360gb HDD (w/ NCQ Support). I installed Fedora Core 6 with "IDE" enabled in the bios instead of "AHCI". After installing Fedora Core 6 and tweaking it I decided to activate "AHCI" in the hopes that it would work flawlessly, but I was wrong. Fedora Core 6 does not boot with "AHCI" activated. The error I get is that it can't find any LVMs and the kernel panics

    -> uname -r
    2.6.19-1.2895.fc6

    -- My kernel boot options are as follow
    rhgp quiet pci=nommconf all-generic-ide irqpoll

    Any suggestions as to how to fix it?

    THANKS! :)

    Note: BIOS is at it's newest revision.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I'd suggest a clean re-install.
     
  3. juan.villa

    juan.villa New Member

    Reinstall

    Yep, I performed a clean reinstall and I was able to get AHCI support on the fly. I don't believe this should have been the way of doing this, considering the fact that linux is such a flexible operating system. I will look into it in the future, but if anyone has any has any opinions about this you're welcome to post it here. Thanks!
     
  4. falko

    falko Super Moderator ISPConfig Developer

    That's right, but sometimes a reinstall is much faster than trying to find a solution. ;) For example, I have no idea how to get AHCI working on an already installed system.
     

Share This Page