AH01071: Got error 'Primary script unknown\n'

Discussion in 'Installation/Configuration' started by Daninor, Dec 16, 2018.

  1. Daninor

    Daninor New Member

    Hello,

    I am having a problem with my ISPconfig v3.1.13. Everything works fine, but I am having issues entering the "Email" site in the control panel, and every time when I try, I am getting this error message:

    AH01071: Got error 'Primary script unknown\n', referer: https://mysite.com:8080/index.php

    I've tried to search around on Google for a fix, but I cant find any solution.

    Do any of you have a clue what this could be? What other info do you need to help me?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Daninor

    Daninor New Member

    Thanks for your answer. Im running Ubuntu 18.04 with Apache as webserver. I installed Ispconfig by following a guide, and everything worked. But I wanted to install Http/2, and upgrade to php 7.2 fpm aswell so I did that.

    In order to enable http/2 I had to disable «worker» and enable another one (I cant excactly remember what the name for this is, but I believe you understand what I mean?).

    For me it sounds like there is something wrong with php, but I have no clue if this is correct, and what it could be.

    I have run the ISPConfig test script for common issues with output of:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1.13


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 7.2.10-0ubuntu***.***.***.***

    ##### PORT CHECK #####

    [WARN] Port 22 (SSH server) seems NOT to be listening

    ##### MAIL SERVER CHECK #####


    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 6009)
    [INFO] I found the following mail server(s):
    Postfix (PID 1723)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 858)
    [INFO] I found the following imap server(s):
    Dovecot (PID 858)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 1887)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [anywhere]:110 (858/dovecot)
    [anywhere]:143 (858/dovecot)
    [anywhere]:465 (1723/master)
    [anywhere]:21 (1887/pure-ftpd)
    ***.***.***.***:53 (897/named)
    [localhost]:53 (897/named)
    ***.***.***.***:53 (663/systemd-resolve)
    [anywhere]:25 (1723/master)
    [localhost]:953 (897/named)
    [anywhere]:7777 (1331/sshd)
    [anywhere]:993 (858/dovecot)
    [anywhere]:995 (858/dovecot)
    [localhost]:10023 (1580/postgrey)
    [localhost]:10024 (1866/amavisd-new)
    [localhost]:10025 (1723/master)
    [localhost]:10026 (1866/amavisd-new)
    [localhost]:10027 (1723/master)
    [anywhere]:587 (1723/master)
    [localhost]:11211 (872/memcached)
    [localhost]10 (858/dovecot)
    [localhost]43 (858/dovecot)
    *:*:*:*::*:8080 (6009/apache2)
    *:*:*:*::*:80 (6009/apache2)
    *:*:*:*::*:8081 (6009/apache2)
    *:*:*:*::*:465 (1723/master)
    *:*:*:*::*:21 (1887/pure-ftpd)
    *:*:*:*::*:53 (897/named)
    *:*:*:*::*:25 (1723/master)
    *:*:*:*::*:953 (897/named)
    *:*:*:*::*:443 (6009/apache2)
    *:*:*:*::*:7777 (1331/sshd)
    *:*:*:*::*:993 (858/dovecot)
    *:*:*:*::*:995 (858/dovecot)
    *:*:*:*::*:10023 (1580/postgrey)
    *:*:*:*::*:10024 (1866/amavisd-new)
    *:*:*:*::*:10026 (1866/amavisd-new)
    *:*:*:*::*:3306 (1262/mysqld)
    *:*:*:*::*:587 (1723/master)
     
    Last edited: Dec 16, 2018
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  5. Daninor

    Daninor New Member

    Ok, so how do I change it back to 7.0, and enable 7.2 for websites?
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If PHP 7.0 is removed, install it back. Most recently installed PHP is the default.
    Otherwise, use
    Code:
    update-alternatives --config php
    I may have that command wrong, so check if from the tutorial I linked. All of this is explained there.
     
  7. Daninor

    Daninor New Member

    Last edited: Dec 16, 2018
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What did you mean by
     
  9. Daninor

    Daninor New Member

    When I installed Ispconfig, I could not enable the http2 choice. In order to fix that I had to change from php worker to prefork (or opposite, I dont remember). After that I could successfully enable "Enable SPDY/HTTP2" in Ispconfig.

    When I did that, both phpmyadmin and roundcube stopped working. Phpmyadmin only showed text (as if php wasnt working), and roundcube only forced me to download a file when entering /webmail.
     
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Could the above have broken ISPConfig?
     
  11. Daninor

    Daninor New Member

    Thats the problem. Everything works, but not the "Email" one.

    Take a look here, when I press clients, everything works, and the client menu opens correctly.

    [​IMG]

    If I press email right after being in the clients menu, you can see it still says "clients", but as you can see on the left side, "Email accounts" etc. shows up. If I press one of these underneath "Email accounts", nothing happens, and I get this error:

    [proxy_fcgi:error] [pid 2019:tid 140244481459968] [client xxxxxxxxxx] AH01071: Got error 'Primary script unknown\n', referer: https://domain.tld:8080/

    [​IMG]
     
  12. Daninor

    Daninor New Member

    Re-installed server and its working now. But thanks anyway.
     
  13. Jesse Norell

    Jesse Norell Well-Known Member

    Perhaps you had a global /mail alias? That will break the Email tab.
     
    Daninor likes this.
  14. Daninor

    Daninor New Member

    That is actually something I changed, but I did not even know that would make a difference. Good to know, thanks!
     

Share This Page