Again: Co/Sub-domain problem

Discussion in 'Installation/Configuration' started by DrDon, Apr 24, 2007.

  1. DrDon

    DrDon New Member

    Good evening guys and gals,

    i have the following problem:

    I own the domain and a dedicated server.
    Both are hosted at Hetzner. is not using it's own nameservers. (nameservers are and

    The server is running debian etch (The perfect Setup tutorial - Thanks!) and the newest version of ISPConfig.

    Now, i want to create some subdomains (they should point to i.e.)

    So, after what i've read on the forums, i go to my web, click on co-domains, enter drdon as host an as the domain, forward it to and hit save.

    dont work.

    if i enter in my browser, i wont get a site. just a "Server not found" message -.-

    Since i'm kinda new to this, i don't even know if ISPConfig is wholly configured.

    i did not enter any Master/Slave DNS under the "DNS Manager" tab - just the default ns1/ns2 under "Administration -> Server -> Preferences"

    I dont want to create any new, independent webs for the subdomains - just a forward to the users directory.

    The domain is working fine.

    Thanks in advance



    P.S.: Don't ask me why i talk so much of nameservers....i just suspect them to be the bad ones :D
  2. todvard

    todvard ISPConfig Developer ISPConfig Developer

    The "drdon" hostname has to be configured in the DNS server as an A record. Ask your DNS provider to do it.
    In the meantime you can test the forward function by adding to you hosts file (/etc/hosts - in linux; c:\windows\system32\drivers\etc\hosts - in windowsXP), but don't forget, by this way it will work only for you.
  3. DrDon

    DrDon New Member

    thank you!

    Got it fixed, i can add them myself by editing the zonefiles (dont ask me why i did not found them yesterday ^^)

    Now, theres just one question left.

    Can i configure ISPConfig to add the A records to the Nameservers itself?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    First, editing the zonefiles manually is a bad idea as ISPConfig will remove your changes if they are not at the bottom of the file.

    You can easily add DNS A_REcords in the ISPConfig DNS-Manager, manual editing is not nescessary.

Share This Page