After upgrading ISP Config 3 suPHP stopped working

Discussion in 'General' started by eddie67, Jul 14, 2016.

  1. eddie67

    eddie67 New Member


    I recently upgraded two of my VPS'es with Debian 8 to ISP Config

    In both, suPHP stopped to work all together. If I set any site to use suPHP, php is not interpreted at all.
    One thing must be said though, I performed an OS-upgrade at the same time, so I can not be sure which upgrade caused the problem.

    Any suggestions?

    Thank you
    Eddie, Norway
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    which update did you do first? If the OS is upgraded (e.g. from Debian 7 to 8, then the ispconfig update as to be run after the os upgarde and the services need to be reconfigured during update.

    Btw, suPHP is deprecated anyway and should not be used anymore. Better use suexec + php in FastCGI or fpm mode, that's way faster and runs the php script under the web user likes suphp does.
  3. eddie67

    eddie67 New Member

    Thank you for your reply.

    I did an update, rather than an upgrade. My mistake. It was always Debain 8
    And after that, I updated from to

    I have put all my sites to use php-fpm with suexec as per your advice.
    Previous I used fast-CGI but it consumed so much memory that my 2GB VPS failed. Now it seems to run fine.

    Thank you.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You might also want to check the php-fpm details on the options tab of the website, the mode that uses the least resources is the ondemand php-fpm mode.
  5. eddie67

    eddie67 New Member

    Nice! That was helpful. Thank you.

    Actually I have 2 other VPS'es with Debian 7. I tried to change the sites there but on both of them php-fpm does not work. But suPHP works. Could you point me in any direction as to where I can look for issues? Config files?

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely php-fpm and mod_fastcgi (not to mix up with mod_fcgi) is not installed then. See perfect server tutorial for Debian 7 n how to install php-fpm and mod_fastcgi.

Share This Page